aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-06-01 21:49:21 +0200
committerUlrich Müller <ulm@gentoo.org>2016-06-01 21:49:21 +0200
commit67bcfe4cf1874a8571255a9612da75c5c9d1afde (patch)
treedb454cbc2280761d523395a07b7a898a267ca4d2 /configure.ac
parentAvoid absolute paths for programs. (diff)
downloadeselect-67bcfe4cf1874a8571255a9612da75c5c9d1afde.tar.gz
eselect-67bcfe4cf1874a8571255a9612da75c5c9d1afde.tar.bz2
eselect-67bcfe4cf1874a8571255a9612da75c5c9d1afde.zip
Make configure test for git more robust.
* configure.ac: Make testing for git repository more robust.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6fce662..9a72546 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,7 +73,7 @@ AC_SUBST(EPREFIX)
AC_MSG_CHECKING([whether building from git])
EXTRAVERSION=""
eselect_git_dir=${GIT_DIR:-${srcdir}/.git}
-if test -d "${eselect_git_dir}"; then
+if GIT_DIR="${eselect_git_dir}" git rev-parse >/dev/null 2>&1; then
COMMIT=`GIT_DIR="${eselect_git_dir}" git describe --long --always HEAD`
if test x$COMMIT != x; then
EXTRAVERSION=", git commit $COMMIT"