aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-05-15 12:16:51 +0300
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-05-15 12:16:51 +0300
commit53104af3467c846eb48f139204b6e0b1663502b8 (patch)
treece5358eef7ddb33a6b6081f9511eb0ab49ad264a
parentbump e17 vala bindings (diff)
downloadembedded-cross-53104af3467c846eb48f139204b6e0b1663502b8.tar.gz
embedded-cross-53104af3467c846eb48f139204b6e0b1663502b8.tar.bz2
embedded-cross-53104af3467c846eb48f139204b6e0b1663502b8.zip
bump zhone2
zhone2 - phone app written on e17 vala, using only cornucopia, fso2 + zhone2 should be enough to have working phone, without any python running. Signed-off-by: Maksim 'max_posedon' Melnikau <maxposedon@gmail.com>
-rw-r--r--sys-mobilephone/zhone2/Manifest1
-rw-r--r--sys-mobilephone/zhone2/zhone2-9999.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-mobilephone/zhone2/Manifest b/sys-mobilephone/zhone2/Manifest
new file mode 100644
index 0000000..5ca1148
--- /dev/null
+++ b/sys-mobilephone/zhone2/Manifest
@@ -0,0 +1 @@
+EBUILD zhone2-9999.ebuild 835 RMD160 2e39d14183b72e95dc6a4179f1d2915db1af6579 SHA1 b590f7de7090d3b1a157c24bfe64c950e56d069f SHA256 2c417bb35bbb4e44ad3908f2f3da78bdf3e1a8a5d75af1e16cc466415894b5ef
diff --git a/sys-mobilephone/zhone2/zhone2-9999.ebuild b/sys-mobilephone/zhone2/zhone2-9999.ebuild
new file mode 100644
index 0000000..d73492c
--- /dev/null
+++ b/sys-mobilephone/zhone2/zhone2-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit base git autotools
+
+DESCRIPTION=""
+HOMEPAGE="http://www.freesmartphone.org"
+EGIT_REPO_URI="git://git.freesmartphone.org/aurora.git"
+EGIT_PROJECT="aurora"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~x86 ~amd64"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=dev-libs/dbus-glib-0.74
+ >=sys-apps/dbus-1.2.1
+ >=dev-libs/libgee-0.5.0
+ >=sys-mobilephone/libfsobasics-0.9
+ sys-mobilephone/libfso-glib
+ sys-mobilephone/libfsoframework
+ dev-libs/eina
+ media-libs/edje
+ x11-libs/evas
+ x11-libs/ecore
+ x11-libs/elementary
+ dev-libs/libeflvala"
+DEPEND="${RDEPEND}
+ >=dev-lang/vala-0.7.10.5"
+
+src_prepare() {
+ S="${WORKDIR}/${P}/${PN}"
+ cd ${S}
+ eautoreconf
+}
+
+src_configure()
+{
+ econf \
+ $(use_enable debug)
+}