aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'emacs/27.2/04_all_webkit-4.1.patch')
-rw-r--r--emacs/27.2/04_all_webkit-4.1.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/emacs/27.2/04_all_webkit-4.1.patch b/emacs/27.2/04_all_webkit-4.1.patch
new file mode 100644
index 0000000..27637ff
--- /dev/null
+++ b/emacs/27.2/04_all_webkit-4.1.patch
@@ -0,0 +1,26 @@
+Migrate from net-libs/webkit-gtk:4 to :4.1
+Backported from emacs-29 branch
+https://bugs.gentoo.org/893670
+
+commit 7287b7b53a17f9b2d1b474466106806a9d57af47
+Author: Ulrich Müller <ulm@gentoo.org>
+Date: Thu Feb 9 10:58:48 2023 +0100
+
+ Support webkit2gtk-4.1
+
+--- emacs-27.2/configure.ac
++++ emacs-27.2/configure.ac
+@@ -2799,8 +2799,12 @@
+ AC_MSG_ERROR([xwidgets requested but gtk3 not used.])
+
+ WEBKIT_REQUIRED=2.12
+- WEBKIT_MODULES="webkit2gtk-4.0 >= $WEBKIT_REQUIRED"
++ WEBKIT_MODULES="webkit2gtk-4.1 >= $WEBKIT_REQUIRED"
+ EMACS_CHECK_MODULES([WEBKIT], [$WEBKIT_MODULES])
++ if test "$HAVE_WEBKIT" = "no"; then
++ WEBKIT_MODULES="webkit2gtk-4.0 >= $WEBKIT_REQUIRED"
++ EMACS_CHECK_MODULES([WEBKIT], [$WEBKIT_MODULES])
++ fi
+ HAVE_XWIDGETS=$HAVE_WEBKIT
+ test $HAVE_XWIDGETS = yes ||
+ AC_MSG_ERROR([xwidgets requested but WebKitGTK+ not found.])