aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'general-concepts')
-rw-r--r--general-concepts/autotools/text.xml2
-rw-r--r--general-concepts/dependencies/text.xml4
-rw-r--r--general-concepts/ebuild-revisions/text.xml4
-rw-r--r--general-concepts/manifest/text.xml2
-rw-r--r--general-concepts/mirrors/text.xml3
-rw-r--r--general-concepts/sandbox/text.xml2
-rw-r--r--general-concepts/slotting/text.xml4
-rw-r--r--general-concepts/tree/text.xml2
8 files changed, 12 insertions, 11 deletions
diff --git a/general-concepts/autotools/text.xml b/general-concepts/autotools/text.xml
index 02a3554..39edb19 100644
--- a/general-concepts/autotools/text.xml
+++ b/general-concepts/autotools/text.xml
@@ -496,7 +496,7 @@ This is handled via the macro <c>AC_SUBST(VARNAME)</c> in <c>configure.ac</c>.
<p>
Sometimes, badly behaved <c>Makefile.am</c> files will override user variables such
as <c>CFLAGS</c>. This must not be allowed <d/> see
-<uri link="::general-concepts/user-environment/#Not Filtering Variables"/>.
+<uri link="::general-concepts/user-environment/#Not filtering variables"/>.
There are separate special variables which should be used in these situations
<d/> for setting <c>CFLAGS</c>. for example, a <c>Makefile.am</c> should use
<c>AM_CFLAGS</c> so that user preferences are not ignored.
diff --git a/general-concepts/dependencies/text.xml b/general-concepts/dependencies/text.xml
index 29998cd..3201d91 100644
--- a/general-concepts/dependencies/text.xml
+++ b/general-concepts/dependencies/text.xml
@@ -74,7 +74,7 @@ distinctions still apply even if it isn't, strictly speaking, cross-compiling.
<p>
Build dependencies are used to specify any dependencies that are required
to unpack, patch, compile, test or install the package (but see
-<uri link="::general-concepts/dependencies/#Implicit System Dependency"/> for
+<uri link="::general-concepts/dependencies/#Implicit system dependency"/> for
exemptions).
</p>
@@ -382,7 +382,7 @@ DEPEND="qt5? ( ~dev-qt/qtcore-5.15.2:5 )
In <c>EAPI=5</c> and higher, you can use slot operators appended to the package
name to declare whether or not your package should be rebuilt after the versions
satisfying its runtime dependencies are updated to versions with a different slot
-or <uri link="::general-concepts/slotting/#Sub-Slots">sub-slot</uri>:
+or <uri link="::general-concepts/slotting/#Sub-slots">sub-slot</uri>:
</p>
<ul>
diff --git a/general-concepts/ebuild-revisions/text.xml b/general-concepts/ebuild-revisions/text.xml
index d363516..2c8531a 100644
--- a/general-concepts/ebuild-revisions/text.xml
+++ b/general-concepts/ebuild-revisions/text.xml
@@ -7,7 +7,7 @@
<p>
Ebuilds may have a Gentoo revision number associated with them. This is a
<c>-rX</c> suffix, where <c>X</c> is an integer <d/> see
-<uri link="::ebuild-writing/file-format/#File Naming Rules"/>.
+<uri link="::ebuild-writing/file-format/#File naming rules"/>.
This component must only be used for Gentoo changes, not upstream releases.
An ebuild with no explicit revision number has the implicit <c>-r0</c>
revision.
@@ -40,7 +40,7 @@ of thumb could be used as a guideline:
as such), then a new revision should be introduced and the old one
kept. If the package has stable keywords, the new revision should
be dropped to <c>~arch</c> (see
- <uri link="::keywording/#Keywording on Upgrades"/>).
+ <uri link="::keywording/#Keywording on upgrades"/>).
For any such revision bump, the new ebuild should be based
on the previous revision to ensure that fixes aren't dropped
accidentally.
diff --git a/general-concepts/manifest/text.xml b/general-concepts/manifest/text.xml
index 11ed7cb..eb0d700 100644
--- a/general-concepts/manifest/text.xml
+++ b/general-concepts/manifest/text.xml
@@ -70,7 +70,7 @@ longer matches the computed checksum of the fetched distfile.
<p>
Special care is also required with regard to
-<uri link="::general-concepts/mirrors/#Replacing Automatically Mirrored Files">
+<uri link="::general-concepts/mirrors/#Replacing automatically mirrored files">
mirrors</uri>.
</p>
</body>
diff --git a/general-concepts/mirrors/text.xml b/general-concepts/mirrors/text.xml
index 927a3a6..5bc8f73 100644
--- a/general-concepts/mirrors/text.xml
+++ b/general-concepts/mirrors/text.xml
@@ -70,7 +70,8 @@ fetch and start distributing the new version.
<p>
Updating an existing distfile is generally cause for concern and must be done
-with care, see <uri link="::general-concepts/manifest/#Updating Manifests"/>.
+with care, see
+<uri link="::general-concepts/manifest/#Updating Manifest files"/>.
</p>
<p>
diff --git a/general-concepts/sandbox/text.xml b/general-concepts/sandbox/text.xml
index 8dcaeb1..06da4d3 100644
--- a/general-concepts/sandbox/text.xml
+++ b/general-concepts/sandbox/text.xml
@@ -22,7 +22,7 @@ generally <b>not</b> the correct solution.
<p>
See <uri link="::function-reference/sandbox-functions/"/> for details on
sandbox-related functions. See <uri
-link="::appendices/common-problems/#Handling Access Violations"/> for suggestions
+link="::appendices/common-problems/#Handling access violations"/> for suggestions
on fixing sandbox-related build problems.
</p>
</body>
diff --git a/general-concepts/slotting/text.xml b/general-concepts/slotting/text.xml
index a0fb1e1..f45263f 100644
--- a/general-concepts/slotting/text.xml
+++ b/general-concepts/slotting/text.xml
@@ -41,7 +41,7 @@ possible that the user may have <c>foo-2.0</c> installed and no <c>foo-1.x</c> a
<p>
To <c>DEPEND</c> upon a package in a specific slot, refer to
-<uri link="::general-concepts/dependencies/#SLOT Dependencies"/>.
+<uri link="::general-concepts/dependencies/#SLOT dependencies"/>.
</p>
</body>
@@ -55,7 +55,7 @@ but it's undesirable or inconvenient to allow some of these versions to be insta
simultaneously. In <c>EAPI=5</c> and higher, this situation can be handled by
using sub-slots, which are delimited from the regular slot by a <c>/</c> character,
as in <c>SLOT="slot/subslot"</c>. Packages can
-<uri link="::general-concepts/dependencies/#Slot Operators">request to be
+<uri link="::general-concepts/dependencies/#Slot operators">request to be
automatically rebuilt</uri> when the subslot of a runtime dependency changes.
</p>
diff --git a/general-concepts/tree/text.xml b/general-concepts/tree/text.xml
index e686b54..f1877fd 100644
--- a/general-concepts/tree/text.xml
+++ b/general-concepts/tree/text.xml
@@ -102,7 +102,7 @@ U+0021 to U+007E (see also
<uri link="https://www.gentoo.org/glep/glep-0031.html#suitable-characters-for-file-and-directory-names">
GLEP 31</uri>). Any characters that have a special meaning in Bash or in
<c>SRC_URI</c> should also be avoided. If necessary, upstream files can be
-<uri link="::ebuild-writing/variables/#Renaming Sources">renamed</uri> using
+<uri link="::ebuild-writing/variables/#Renaming sources">renamed</uri> using
<c>-&gt;</c> syntax.
</p>