diff options
author | Stanislav Ochotnicky <sochotnicky@gmail.com> | 2009-08-15 20:51:02 +0200 |
---|---|---|
committer | Stanislav Ochotnicky <sochotnicky@gmail.com> | 2009-08-15 21:21:40 +0200 |
commit | 22e9992cbc11dc7dfc757a3d94262fa762c73ea7 (patch) | |
tree | 0ebb96ce26710a4988720ab07b3915751c96215d | |
parent | Added installation of example settings (diff) | |
download | collagen-22e9992cbc11dc7dfc757a3d94262fa762c73ea7.tar.gz collagen-22e9992cbc11dc7dfc757a3d94262fa762c73ea7.tar.bz2 collagen-22e9992cbc11dc7dfc757a3d94262fa762c73ea7.zip |
Updated installation instructionsrelease-1.0
also moved initialization data so that it is installed in /usr/share
-rw-r--r-- | INSTALL | 40 | ||||
-rw-r--r-- | examples/tinderbox_config.py | 4 | ||||
-rw-r--r-- | initial_data.json (renamed from src/collagen/matchbox/db/main/initial_data.json) | 0 | ||||
-rw-r--r-- | setup.py | 3 | ||||
-rw-r--r-- | web/- | 0 |
5 files changed, 28 insertions, 19 deletions
@@ -7,35 +7,42 @@ Dependencies: - Working PostgreSQL database * Tinderbox - running as root +Easiest way to install collagen is by using python setup.py script: + # python setup.py install +This will install collagen python files, data and wrapper scrips. - ==================== INSTALLING Matchbox ==================== +Alternatively you can use ebuild file included with distribution. + + + ==================== Configuring Matchbox ==================== First we need to setup database connection. This is done by setting -variables in src/matchbox/db/settings.py. Now initialization of db -schema is in order. We use django tools to create it for us from model -description. For initialization do this(in collagen root directory): +variables in configuration module for django (example file can be +found at /usr/share/doc/collagen-1.0/db_config.py). Now initialization +of db schema is in order. We use django tools to create it for us from +model description. For initialization do this: -cd src/ -django-admin.py syncdb --settings=matchbox.db.settings --pythonpath=. -django-admin.py loaddata matchbox/db/main/initial_data.json \ - --settings=matchbox.db.settings --pythonpath=. + $ django-admin.py syncdb --settings=db_config --pythonpath=. + $ django-admin.py loaddata /usr/share/collagen-1.0/initial_data.json \ + --settings=db_config --pythonpath=. If the database schema exists and you need to fix it, drop the tables -beforehand, because django-admin.py will skips tables that exist +beforehand, because django-admin.py will skip tables that exist already. -All we need to do now is start the server: +All we need to do now is start the server (can be run as regular user) -python matchbox.py + $ matchbox.py - ==================== INSTALLING Tinderbox ==================== + ==================== Configuring Tinderbox ==================== This is a little bit easier than Matchbox. We need to set path of -mktinderboxchroot.sh script in src/tinderbox/config.py. This is done -by setting variable MK_CHROOT_SCRIPT. +mktinderboxchroot.sh script and few other settings in tinderbox +configuration file (example can be found at +/usr/share/doc/collagen-1.0/tinderbox_config.py). Other variables that need to be setup are: MATCHBOX_HOST - ip or hostname of matchbox host @@ -53,6 +60,7 @@ CHROOT_LOGS - this is directory inside WORK_CHROOT where logging and LOG_LEVEL - you can leave this to log.DEBUG until collagen is rock-solid :-) -Now we need to run tinderbox: +Now we need to run tinderbox with tinderbox_config.py in current dir +(as root): -sudo python tinderbox.py
\ No newline at end of file + # tinderbox.py
\ No newline at end of file diff --git a/examples/tinderbox_config.py b/examples/tinderbox_config.py index d6c1d48..91bab3b 100644 --- a/examples/tinderbox_config.py +++ b/examples/tinderbox_config.py @@ -1,10 +1,10 @@ MATCHBOX_HOST="localhost" MATCHBOX_PORT=10000 -MK_CHROOT_SCRIPT="/usr/sbin/mktinderboxchroot.sh" +MK_CHROOT_SCRIPT="/usr/bin/mktinderboxchroot.sh" STAGE_TARBALL="/data/downloads/stage3-i686-2008.0.tar.bz2" -WORKDIR="/data/temp" +WORKDIR="/collagen" BASE_CHROOT=WORKDIR+"/collagen-base-chroot" WORK_CHROOT=WORKDIR+"/collagen-work-chroot" diff --git a/src/collagen/matchbox/db/main/initial_data.json b/initial_data.json index 613b7a5..613b7a5 100644 --- a/src/collagen/matchbox/db/main/initial_data.json +++ b/initial_data.json @@ -16,7 +16,8 @@ for dirpath, dirnames, filenames in os.walk('examples/'): for fname in filenames: webfiles.append((dirprefix, [os.path.join(dirpath, fname)])) - +dirprefix = "/usr/share/collagen-%s" % VERSION +webfiles.append((dirprefix, ['initial_data.json'])) setup(name='Collagen', version=VERSION, |