summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'toolbin')
-rw-r--r--toolbin/genfontmap.ps6
-rwxr-xr-xtoolbin/localcluster/clusterpush.pl2
2 files changed, 6 insertions, 2 deletions
diff --git a/toolbin/genfontmap.ps b/toolbin/genfontmap.ps
index cf9ed12d..913af2b9 100644
--- a/toolbin/genfontmap.ps
+++ b/toolbin/genfontmap.ps
@@ -58,8 +58,10 @@ QUIET not {
% Create an array so we can sort it
+mark
Fontmap { [ 3 1 roll ] } forall
-count array astore
+.nativeFontmap { [ 3 1 roll ] } forall
+counttomark array astore exch pop
% sort the array
{ 0 get 100 string cvs exch 0 get 100 string cvs gt } .sort
@@ -75,6 +77,6 @@ count array astore
flush
(\ngenfontmap completed OK. ) =error
-Fontmap length Initial_count sub 10 string cvs =error
+Fontmap length .nativeFontmap length add Initial_count sub 10 string cvs =error
( new fonts added.\n\n) =error
quit
diff --git a/toolbin/localcluster/clusterpush.pl b/toolbin/localcluster/clusterpush.pl
index 7d998e7e..aaaa9cb2 100755
--- a/toolbin/localcluster/clusterpush.pl
+++ b/toolbin/localcluster/clusterpush.pl
@@ -30,6 +30,7 @@ my %products=('abort' =>1,
'extract'=>1,
'extractmu'=>1,
'muwasm'=>1,
+ 'mucsharp'=>1,
'extractgs'=>1);
my $rsync_L = "";
@@ -249,6 +250,7 @@ $cmd .= " --max-size=30000000".
" --exclude debug --exclude release --exclude generated --exclude sanitize". # we cannot just exclude build, since tiff/build/Makefile.in, etc. is needed
" --exclude tiff-config".
" --exclude 'shared-*'".
+" --exclude user.make".
# Exclude files generated by scripts/mupdfwrap.py:
" --exclude mupdfwrap_ref".