summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Böhm <bb@xnull.de>2010-09-09 08:45:23 +0200
committerBenedikt Böhm <bb@xnull.de>2010-09-09 08:45:23 +0200
commit6ac943ed3adef2a68ca43aa7f6d51a6345b28b36 (patch)
treedaebc1c5ab4ec4be97a7fee40460655c033cd836 /dev-ruby
parentversion bump (diff)
downloadbetagarden-6ac943ed3adef2a68ca43aa7f6d51a6345b28b36.tar.gz
betagarden-6ac943ed3adef2a68ca43aa7f6d51a6345b28b36.tar.bz2
betagarden-6ac943ed3adef2a68ca43aa7f6d51a6345b28b36.zip
add bundler-1.0.0
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bundler/Manifest2
-rw-r--r--dev-ruby/bundler/bundler-1.0.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/bundler/Manifest b/dev-ruby/bundler/Manifest
new file mode 100644
index 0000000..0ba01f9
--- /dev/null
+++ b/dev-ruby/bundler/Manifest
@@ -0,0 +1,2 @@
+DIST bundler-git-1.0.0.tgz 127627 RMD160 52f4643c0ed8f9b8833c49877201e9eb3de081f5 SHA1 90c8d998f1fd6a2705d682dd75d5ccfe4ad4a273 SHA256 5181c125652a21f38777c45e43d12ee1e57835602fded3ce6ff5ef0ccfab6953
+EBUILD bundler-1.0.0.ebuild 1029 RMD160 f932cd9e1accf4d8b64972e1728854397406d145 SHA1 b1c890449327463121237e22c6efa384ca6afadc SHA256 70bf21defde097a4d731ba2f9df9df47d893536c4637f42d5f6929940442f80b
diff --git a/dev-ruby/bundler/bundler-1.0.0.ebuild b/dev-ruby/bundler/bundler-1.0.0.ebuild
new file mode 100644
index 0000000..9009ca2
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-0.9.26.ebuild,v 1.2 2010/06/30 12:05:31 flameeyes Exp $
+
+EAPI=2
+
+# ruby19 → uncountable number of test failures
+# jruby → needs to be tested because jruby-1.5.1 fails in multiple
+# ways unrelated to this package
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ROADMAP.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="http://github.com/carlhuda/bundler"
+
+GITHUB_USER="carlhuda"
+SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/${GITHUB_USER}-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/rubygems
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"
+
+RDEPEND="${RDEPEND}
+ dev-vcs/git"
+DEPEND="${DEPEND}
+ test? ( dev-vcs/git )"