summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-06-01 22:16:21 +0200
committerSebastian Pipping <sping@gentoo.org>2010-06-01 22:18:39 +0200
commit1ae374033fe65a8cb72707850f8aa5b9c20e6a5c (patch)
tree5e9f0755a9925bc4fb233a5ec02772c5a668f37b /app-editors
parentSet repo_name (diff)
downloadbetagarden-1ae374033fe65a8cb72707850f8aa5b9c20e6a5c.tar.gz
betagarden-1ae374033fe65a8cb72707850f8aa5b9c20e6a5c.tar.bz2
betagarden-1ae374033fe65a8cb72707850f8aa5b9c20e6a5c.zip
Migrate some ebuilds from sping overlay
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/texworks/Manifest3
-rw-r--r--app-editors/texworks/files/icon/texworks.pngbin0 -> 2575 bytes
-rw-r--r--app-editors/texworks/files/texworks.desktop21
-rw-r--r--app-editors/texworks/texworks-9999-r4.ebuild31
4 files changed, 55 insertions, 0 deletions
diff --git a/app-editors/texworks/Manifest b/app-editors/texworks/Manifest
new file mode 100644
index 0000000..c990ad9
--- /dev/null
+++ b/app-editors/texworks/Manifest
@@ -0,0 +1,3 @@
+AUX icon/texworks.png 2575 RMD160 ed62c403a3ae55d25a8b68740eb2b95f67b2a48b SHA1 2b407b19b950589f9291216a31563ed38637ca41 SHA256 b557047947474a278301647a4a2ff0a7b361a82691ec0fbb515f023e59ed8ac7
+AUX texworks.desktop 475 RMD160 86bcba7d39dd2dac683604f2906b73e8bac52a8f SHA1 64dfcf77c05c6b99bc040bce4e82ae411aa6e2c3 SHA256 db051c769a9e815196e4a7a4e107f4bf5007b859b45f8e5f8093de5164a2cd2a
+EBUILD texworks-9999-r4.ebuild 774 RMD160 ff023c597421788d439f03462ef194db8c2a3803 SHA1 984ed236b0858731712904fa5a2357f3c601b8eb SHA256 df66612b8c3a5871af2af738d0bb3db222f55cb19e468ee3e895c45a6aed73b6
diff --git a/app-editors/texworks/files/icon/texworks.png b/app-editors/texworks/files/icon/texworks.png
new file mode 100644
index 0000000..349b331
--- /dev/null
+++ b/app-editors/texworks/files/icon/texworks.png
Binary files differ
diff --git a/app-editors/texworks/files/texworks.desktop b/app-editors/texworks/files/texworks.desktop
new file mode 100644
index 0000000..f516483
--- /dev/null
+++ b/app-editors/texworks/files/texworks.desktop
@@ -0,0 +1,21 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Name=TeXworks
+Name[zh_CN]=TeXworks
+Name[zh_HK]=TeXworks
+Name[zh_TW]=TeXworks
+GenericName=TeX Editor
+GenericName[zh_CN]=TeX编辑器
+GenericName[zh_HK]=TeX編輯器
+GenericName[zh_TW]=TeX編輯器
+Comment=Edit TeX documents
+Comment[zh_CN]=编辑TeX文档
+Comment[zh_HK]=編輯TeX文檔
+Comment[zh_TW]=編輯TeX文檔
+Exec=texworks
+Icon=texworks
+Terminal=false
+Type=Application
+MimeType=text/x-tex;
+Categories=Development;TextEditor;
diff --git a/app-editors/texworks/texworks-9999-r4.ebuild b/app-editors/texworks/texworks-9999-r4.ebuild
new file mode 100644
index 0000000..a2e8f32
--- /dev/null
+++ b/app-editors/texworks/texworks-9999-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="2"
+
+inherit eutils qt4-r2 subversion
+
+DESCRIPTION="Environment for authoring TeX/LaTeX/ConTeXt with focus on usability"
+HOMEPAGE="http://code.google.com/p/texworks"
+ESVN_REPO_URI="http://texworks.googlecode.com/svn/trunk/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=">=x11-libs/qt-core-4.5
+ app-text/poppler[qt4]
+ >=app-text/hunspell-1.2.2"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/texworks.desktop || die "Install texwork.desktop failed!"
+
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}"/icon/texworks.png || die "Install texwork icon failed!"
+
+ dobin texworks || die 'dobin failed'
+}