summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-22 12:17:01 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-22 12:17:01 +0200
commit329945a1cf9a7505a8d79d2035b7f35f5d5a983f (patch)
tree9c7c56474c9fcb88bdddc3a50bf44dcf2f2fea27 /app-crypt
parentapp-portage/update-notifier-tray: 1.1 (diff)
downloadbetagarden-329945a1cf9a7505a8d79d2035b7f35f5d5a983f.tar.gz
betagarden-329945a1cf9a7505a8d79d2035b7f35f5d5a983f.tar.bz2
betagarden-329945a1cf9a7505a8d79d2035b7f35f5d5a983f.zip
app-crypt/onetime: Clean old and move to new python eclass
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/onetime/Manifest4
-rw-r--r--app-crypt/onetime/onetime-1.111.ebuild29
-rw-r--r--app-crypt/onetime/onetime-1.115.ebuild29
-rw-r--r--app-crypt/onetime/onetime-1.81.ebuild (renamed from app-crypt/onetime/onetime-1.110.ebuild)19
4 files changed, 12 insertions, 69 deletions
diff --git a/app-crypt/onetime/Manifest b/app-crypt/onetime/Manifest
index c783905..5f0105c 100644
--- a/app-crypt/onetime/Manifest
+++ b/app-crypt/onetime/Manifest
@@ -1,3 +1 @@
-DIST onetime-1.110.tar.gz 1791406 SHA256 20968b217765f3e5f79c9d54109b52f376bb95770fd946665ea048f2b862229a
-DIST onetime-1.111.tar.gz 1791420 SHA256 865bf59d6dfebf1a096dfe62717655238a20691ba90d60b8fe0f2f47a80b4808
-DIST onetime-1.115.tar.gz 1791464 SHA256 725948b3caaab7a4023ed1f3dba2a18823e03c533503ee1eef94c2ed9244a007
+DIST onetime-1.81.tar.gz 1810196 SHA256 36a83a83ac9f4018278bf48e868af00f3326b853229fae7e43b38d167e628348 SHA512 c8ab6efea6c279a508acd9f9e5fdd7e737013076d6042fe977e69da2da311b938efa8b5c44cbeb033ee80b1df0c53fe4a1e8aba0981ca8ab2e55b537521ccaeb WHIRLPOOL 4a2fa77c2b8367b698a82a393004556ac9ecab2a44676546122bd83ad773fd25bee0e15a14ecdd72331a10c1a495e983a0ddf603f833d563d00fdf4186b9d07c
diff --git a/app-crypt/onetime/onetime-1.111.ebuild b/app-crypt/onetime/onetime-1.111.ebuild
deleted file mode 100644
index 9f2631f..0000000
--- a/app-crypt/onetime/onetime-1.111.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-PYTHON_DEPEND="2"
-
-inherit python
-
-DESCRIPTION="An Encoder/Decoder Using The 'One-Time Pad' Method"
-HOMEPAGE="http://www.red-bean.com/onetime/"
-SRC_URI="http://www.red-bean.com/${PN}/${P}.tar.gz"
-
-LICENSE="CC-PD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_compile() {
- :
-}
-
-src_install() {
- dobin onetime || die
- dodoc README || die
-}
diff --git a/app-crypt/onetime/onetime-1.115.ebuild b/app-crypt/onetime/onetime-1.115.ebuild
deleted file mode 100644
index 9f2631f..0000000
--- a/app-crypt/onetime/onetime-1.115.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-PYTHON_DEPEND="2"
-
-inherit python
-
-DESCRIPTION="An Encoder/Decoder Using The 'One-Time Pad' Method"
-HOMEPAGE="http://www.red-bean.com/onetime/"
-SRC_URI="http://www.red-bean.com/${PN}/${P}.tar.gz"
-
-LICENSE="CC-PD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_compile() {
- :
-}
-
-src_install() {
- dobin onetime || die
- dodoc README || die
-}
diff --git a/app-crypt/onetime/onetime-1.110.ebuild b/app-crypt/onetime/onetime-1.81.ebuild
index 9f2631f..ce33ba7 100644
--- a/app-crypt/onetime/onetime-1.110.ebuild
+++ b/app-crypt/onetime/onetime-1.81.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
-PYTHON_DEPEND="2"
+EAPI=5
-inherit python
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
DESCRIPTION="An Encoder/Decoder Using The 'One-Time Pad' Method"
HOMEPAGE="http://www.red-bean.com/onetime/"
@@ -16,14 +17,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${DEPEND}"
src_compile() {
:
}
src_install() {
- dobin onetime || die
- dodoc README || die
+ python_foreach_impl python_doscript ${PN}
+ dodoc README
}