summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-08-30 19:40:43 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-10-19 16:13:01 +0900
commit0cc6c9e8df77aa5deff85aa490e4bbace675de82 (patch)
tree98c71f4ddb4ad1224fe8e9e2c1beea4bd6f7e66d /sys-libs/glibc/files/2.17/glibc-2.17-shadow-prefix.patch
parentclean up ebuilds. (diff)
downloadandroid-0cc6c9e8df77aa5deff85aa490e4bbace675de82.tar.gz
android-0cc6c9e8df77aa5deff85aa490e4bbace675de82.tar.bz2
android-0cc6c9e8df77aa5deff85aa490e4bbace675de82.zip
glibc: need to be kept for RHEL 5, etc.
Diffstat (limited to 'sys-libs/glibc/files/2.17/glibc-2.17-shadow-prefix.patch')
-rw-r--r--sys-libs/glibc/files/2.17/glibc-2.17-shadow-prefix.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/glibc/files/2.17/glibc-2.17-shadow-prefix.patch b/sys-libs/glibc/files/2.17/glibc-2.17-shadow-prefix.patch
new file mode 100644
index 0000000..0e3979c
--- /dev/null
+++ b/sys-libs/glibc/files/2.17/glibc-2.17-shadow-prefix.patch
@@ -0,0 +1,33 @@
+Index: shadow/Makefile
+===================================================================
+--- shadow/Makefile.orig
++++ shadow/Makefile
+@@ -20,6 +20,8 @@
+ #
+ subdir := shadow
+
++include ../Makeconfig
++
+ headers = shadow.h
+ routines = getspent getspnam sgetspent fgetspent putspent \
+ getspent_r getspnam_r sgetspent_r fgetspent_r \
+@@ -34,5 +36,6 @@ CFLAGS-fgetspent_r.c = -fexceptions $(li
+ CFLAGS-putspent.c = -fexceptions $(libio-mtsafe)
+ CFLAGS-getspnam.c = -fexceptions
+ CFLAGS-getspnam_r.c = -fexceptions
++CPPFLAGS-lckpwdf.c = -DSYSCONFDIR='"$(sysconfdir)"'
+
+ include ../Rules
+Index: shadow/lckpwdf.c
+===================================================================
+--- shadow/lckpwdf.c.orig
++++ shadow/lckpwdf.c
+@@ -29,7 +29,7 @@
+
+
+ /* Name of the lock file. */
+-#define PWD_LOCKFILE "/etc/.pwd.lock"
++#define PWD_LOCKFILE SYSCONFDIR "/.pwd.lock"
+
+ /* How long to wait for getting the lock before returning with an
+ error. */