aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdhemerval Zanella <adhemerval.zanella@linaro.org>2019-04-12 17:39:53 -0300
committerAdhemerval Zanella <adhemerval.zanella@linaro.org>2019-04-17 11:35:59 -0300
commit0e169691290a6d2187a4ff41495fc5678cbfdcdc (patch)
tree22a279438012ed4e10b4477fe8a9d0a03a2630e6 /support/Makefile
parentstdlib/tst-secure-getenv: handle >64 groups (diff)
downloadglibc-0e169691290a6d2187a4ff41495fc5678cbfdcdc.tar.gz
glibc-0e169691290a6d2187a4ff41495fc5678cbfdcdc.tar.bz2
glibc-0e169691290a6d2187a4ff41495fc5678cbfdcdc.zip
support: Add support_capture_subprogram
Its API is similar to support_capture_subprocess, but rather creates a new process based on the input path and arguments. Under the hoods it uses posix_spawn to create the new process. It also allows the use of other support_capture_* functions to check for expected results and free the resources. Checked on x86_64-linux-gnu. * support/Makefile (libsupport-routines): Add support_subprocess, xposix_spawn, xposix_spawn_file_actions_addclose, and xposix_spawn_file_actions_adddup2. (tst-support_capture_subprocess-ARGS): New rule. * support/capture_subprocess.h (support_capture_subprogram): New prototype. * support/support_capture_subprocess.c (support_capture_subprocess): Refactor to use support_subprocess and support_capture_poll. (support_capture_subprogram): New function. * support/tst-support_capture_subprocess.c (write_mode_to_str, str_to_write_mode, test_common, parse_int, handle_restart, do_subprocess, do_subprogram, do_multiple_tests): New functions. (do_test): Add support_capture_subprogram tests. * support/subprocess.h: New file. * support/support_subprocess.c: Likewise. * support/xposix_spawn.c: Likewise. * support/xposix_spawn_file_actions_addclose.c: Likewise. * support/xposix_spawn_file_actions_adddup2.c: Likewise. * support/xspawn.h: Likewise. Reviewed-by: Carlos O'Donell <carlos@redhat.com>
Diffstat (limited to 'support/Makefile')
-rw-r--r--support/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/support/Makefile b/support/Makefile
index f173565202..574e34cf1b 100644
--- a/support/Makefile
+++ b/support/Makefile
@@ -63,6 +63,7 @@ libsupport-routines = \
support_record_failure \
support_run_diff \
support_shared_allocate \
+ support_subprocess \
support_test_compare_blob \
support_test_compare_failure \
support_test_compare_string \
@@ -151,6 +152,9 @@ libsupport-routines = \
xsignal \
xsigstack \
xsocket \
+ xposix_spawn \
+ xposix_spawn_file_actions_addclose \
+ xposix_spawn_file_actions_adddup2 \
xstrdup \
xstrndup \
xsymlink \
@@ -226,4 +230,6 @@ endif
$(objpfx)tst-support_format_dns_packet: $(common-objpfx)resolv/libresolv.so
+tst-support_capture_subprocess-ARGS = -- $(host-test-program-cmd)
+
include ../Rules