aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2022-03-15 08:52:30 -0700
committerH.J. Lu <hjl.tools@gmail.com>2022-03-16 06:43:24 -0700
commita8b34706ef017a2032a78892a8595d36029f85a3 (patch)
tree0d27772419e172fad7c6b1209caba2bdda3602b5 /gprofng/libcollector/Makefile.am
parentgprofng: Define ATTRIBUTE_FALLTHROUGH (diff)
downloadbinutils-gdb-a8b34706ef017a2032a78892a8595d36029f85a3.tar.gz
binutils-gdb-a8b34706ef017a2032a78892a8595d36029f85a3.tar.bz2
binutils-gdb-a8b34706ef017a2032a78892a8595d36029f85a3.zip
gprofng: Don't hardcode -Wno-nonnull-compare
Use -Wno-nonnull-compare only if it is supported. PR gprof/28969 * libcollector/Makefile.am (AM_CFLAGS): Replace -Wno-nonnull-compare with GPROFNG_NO_NONNULL_COMPARE_CFLAGS. * libcollector/configure.ac (GPROFNG_NO_NONNULL_COMPARE_CFLAGS): New AC_SUBST for -Wno-nonnull-compare. * libcollector/Makefile.in: Regenerate. * libcollector/aclocal.m4: Likewise. * libcollector/configure: Likewise.
Diffstat (limited to 'gprofng/libcollector/Makefile.am')
-rw-r--r--gprofng/libcollector/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gprofng/libcollector/Makefile.am b/gprofng/libcollector/Makefile.am
index a41b92030e0..901d9a5f0ee 100644
--- a/gprofng/libcollector/Makefile.am
+++ b/gprofng/libcollector/Makefile.am
@@ -41,7 +41,7 @@ CSOURCES = \
collector.c \
$(NULL)
-AM_CFLAGS = $(GPROFNG_CFLAGS) -Wno-nonnull-compare
+AM_CFLAGS = $(GPROFNG_CFLAGS) $(GPROFNG_NO_NONNULL_COMPARE_CFLAGS)
AM_CPPFLAGS = $(GPROFNG_CPPFLAGS) -I.. -I$(srcdir) \
-I$(srcdir)/../common -I$(srcdir)/../src \
-I$(srcdir)/../../include