summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 9b466b0..2a4240e 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -45,7 +45,7 @@ pkg_setup() {
MAKE_ARGS="${MAKE_ARGS} OS=FreeBSD SUBOS=BSD"
brand="FreeBSD"
fi
- [ -n "${brand}" ] && MAKE_ARGS="${MAKE_ARGS} BRANDING=Gentoo/${brand}"
+ [ -n "${brand}" ] && MAKE_ARGS="${MAKE_ARGS} BRANDING=Gentoo\040${brand}"
use ncurses && MAKE_ARGS="${MAKE_ARGS} MKTERMCAP=ncurses"
if use pam; then
@@ -128,8 +128,9 @@ pkg_preinst() {
pkg_postinst() {
# Remove old baselayout links
- rm -rf "${ROOT}"etc/runlevels/boot/checkfs \
- "${ROOT}"etc/runlevels/boot/checkroot
+ rm -f "${ROOT}"etc/runlevels/boot/checkfs \
+ "${ROOT}"etc/runlevels/boot/checkroot \
+ "${ROOT}"etc/runlevels/boot/rmnologin
# Make our runlevels if they don't exist or we're a development version.
if [ ! -e "${ROOT}"etc/runlevels -o "${PV}" = "9999" ]; then