summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-11 17:19:08 +0200
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-11 17:19:08 +0200
commit0b7c2acbf483bce70467a62cf0526b951e35ab33 (patch)
treea4181c0e56868f013365833f7eb10e29c93780e6
parentAdding net-p2p/Circle-0.41c (diff)
downloadsochotnicky-0b7c2acbf483bce70467a62cf0526b951e35ab33.tar.gz
sochotnicky-0b7c2acbf483bce70467a62cf0526b951e35ab33.tar.bz2
sochotnicky-0b7c2acbf483bce70467a62cf0526b951e35ab33.zip
Replaced deprecated python_version call
also fixed html documentation installation destination
-rw-r--r--net-p2p/Circle/Circle-0.41c.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-p2p/Circle/Circle-0.41c.ebuild b/net-p2p/Circle/Circle-0.41c.ebuild
index 3eb70c2..bd0ab3a 100644
--- a/net-p2p/Circle/Circle-0.41c.ebuild
+++ b/net-p2p/Circle/Circle-0.41c.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-p2p/Circle/Circle-0.41c.ebuild,v 1.4 2005/09/06 21:49:32 sekretarz Exp $
@@ -25,20 +25,19 @@ src_compile() {
}
src_install() {
- python_version
exeinto /usr/bin/
doexe circle
- insinto /usr/lib/python${PYVER}/site-packages/circlelib/
+ insinto ${python_get_sitedir}/circlelib
doins circlelib/*.py
- insinto /usr/lib/python${PYVER}/site-packages/circlelib/pixmaps/
+ insinto ${python_get_sitedir}/circlelib/pixmaps
doins circlelib/pixmaps/*
- insinto /usr/lib/python${PYVER}/site-packages/circlelib/crypto/
+ insinto ${python_get_sitedir}/circlelib/crypto/
doins circlelib/crypto/*
- insinto /usr/lib/python${PYVER}/site-packages/circlelib/ui_gtk/
+ insinto ${python_get_sitedir}/circlelib/ui_gtk/
doins circlelib/ui_gtk/*
- insinto /usr/lib/python${PYVER}/site-packages/circlelib/ui_http/
+ insinto ${python_get_sitedir}/circlelib/ui_http/
doins circlelib/ui_http/*
- insinto /usr/lib/python${PYVER}/site-packages/circlelib/ui_text/
+ insinto ${python_get_sitedir}/circlelib/ui_text/
doins circlelib/ui_text/*
insinto /usr/share/pixmaps/
doins circle-icon.png
@@ -46,6 +45,6 @@ src_install() {
insinto /usr/share/gnome/apps/Internet/
doins circle.desktop
fi
- dohtml circlelib/*.html
+ dohtml circlelib/html/*.html
dodoc NEWS PKG-INFO README
}