summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-06-19 08:41:06 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-06-19 08:41:06 -0700
commitced651e390b3ffba81059cb67a4ba946bc7a6a0d (patch)
tree176c9e63c8edc0f8781c8ec1321d3f539d3b05f5 /media-libs
parentupdate local stuff in my repo. (diff)
parentAdd my local stuff again. (diff)
downloadrobbat2-ced651e390b3ffba81059cb67a4ba946bc7a6a0d.tar.gz
robbat2-ced651e390b3ffba81059cb67a4ba946bc7a6a0d.tar.bz2
robbat2-ced651e390b3ffba81059cb67a4ba946bc7a6a0d.zip
Merge remote-tracking branch 'bohr/master'
With conflict fixes Conflicts: metadata/layout.conf profiles/repo_name x11-plugins/pidgin-extended_blist_sort/Manifest x11-plugins/pidgin-toobars/Manifest
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libhashab/Manifest1
-rw-r--r--media-libs/libhashab/libhashab-0_alpha20131216.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/libhashab/Manifest b/media-libs/libhashab/Manifest
new file mode 100644
index 0000000..7da5321
--- /dev/null
+++ b/media-libs/libhashab/Manifest
@@ -0,0 +1 @@
+DIST libhashab-2b6e8d35aeba3a55bd87f6c1a57bf71491029caf.zip 827454 SHA256 778e67a184ad050c8f7ad82cc7398ba773247d6d16439c87ae5d8c8b6c29ed4d SHA512 9d9a51b39fea9e9365f971df24b6abdcba88d7d70acf740d357af5d6bd88e7c12337b20456cc7a4ac612c70970af9e431d6359e01af3216d1e05a13dce720368 WHIRLPOOL fbc03ac775ad85354835a18610f5a9f2d8cfad9df9de9a56c285b881e7db7ba2aa64f9505cc4e13a173b9ca8c079b901a122386cc589220a6b73604491c526ce
diff --git a/media-libs/libhashab/libhashab-0_alpha20131216.ebuild b/media-libs/libhashab/libhashab-0_alpha20131216.ebuild
new file mode 100644
index 0000000..824ecb0
--- /dev/null
+++ b/media-libs/libhashab/libhashab-0_alpha20131216.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit multilib
+
+GITHUB_REV=2b6e8d35aeba3a55bd87f6c1a57bf71491029caf
+MY_P="libhashab-${GITHUB_REV}"
+DESCRIPTION="libgpod extension to make it talk to iPod nano 6th generation"
+HOMEPAGE="https://github.com/denydias/libhashab"
+SRC_URI="https://github.com/denydias/libhashab/archive/${GITHUB_REV}.zip -> ${MY_P}.zip"
+
+LICENSE="Apple" # upstream has no license, and was reverse-engineered from Apple binaries
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+# The multilib dep is NOT an error
+# this is a 32-bit .so library, as well as a 64-bit .so the wraps calling
+RDEPEND=">=media-libs/libgpod-0.8.3
+ sys-libs/glibc[multilib]
+ sys-apps/util-linux"
+RESTRICT="bindist mirror strip"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ LIBDIR_32=/usr/$(get_abi_LIBDIR x86)/libgpod
+ sed -i \
+ -e "s,/usr/lib/x86_64-linux-gnu/libgpod/libhashab32.so,${LIBDIR_32}/libhashab.so," \
+ src/libhashab32_wrapper.c
+ sed -i \
+ -e "/linux32/s,/usr/lib/x86_64-linux-gnu/libgpod/libhashab32_wrapper,${LIBDIR_32}/libhashab32_wrapper,g" \
+ ./src/libhashab.c
+ sed -i \
+ -e '/gcc.*\.c/s,$, $CFLAGS,g' \
+ -e '/gcc.*-o/s,$, $LDFLAGS,g' \
+ src/build.sh
+}
+
+src_compile() {
+ if use amd64; then
+ cd src && ./build.sh
+ fi
+}
+
+src_install() {
+ LIBDIR_32=/usr/$(get_abi_LIBDIR x86)/libgpod
+ exeinto ${LIBDIR_32}
+ newexe libhashab32.so libhashab.so
+ if use amd64; then
+ LIBDIR_64=/usr/$(get_abi_LIBDIR amd64)/libgpod
+ cd src
+ exeinto ${LIBDIR_32}
+ doexe libhashab32_wrapper
+ exeinto ${LIBDIR_64}
+ doexe libhashab.so
+ fi
+}