summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-05-24 21:03:40 +0000
committerRichard Brown <rbrown@gentoo.org>2007-05-24 21:03:40 +0000
commit6f2c8ed48b3d9eb07d49a06b3c685ba3420b00a4 (patch)
tree02f727d09ae7477aba533fde0d232aa8bc2c4c7c
parentAdd ~x86 keywords (diff)
downloadrbrown-6f2c8ed48b3d9eb07d49a06b3c685ba3420b00a4.tar.gz
rbrown-6f2c8ed48b3d9eb07d49a06b3c685ba3420b00a4.tar.bz2
rbrown-6f2c8ed48b3d9eb07d49a06b3c685ba3420b00a4.zip
Strip -O2 it's causing segfaults. actually regenerate the swig file.
svn path=/; revision=29
-rw-r--r--dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1-r1.ebuild b/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1-r1.ebuild
index f7f077b..1902d73 100644
--- a/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1-r1.ebuild
+++ b/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1.ebuild,v 1.3 2007/03/04 00:15:40 genone Exp $
-inherit ruby
+inherit ruby flag-o-matic
DESCRIPTION="An extension library to access a SQLite database from Ruby"
HOMEPAGE="http://rubyforge.org/projects/sqlite-ruby/"
@@ -34,9 +34,12 @@ pkg_setup() {
}
src_compile() {
+ replace-flags -O2 -O1
myconf=""
if ! use swig ; then
myconf="--without-ext"
+ else
+ rm ext/sqlite3_api/sqlite3_api_wrap.c || die "unable to remove swig file"
fi
${RUBY} setup.rb config --prefix=/usr ${myconf} \