summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/man-db/man-db-2.5.3.ebuild')
-rw-r--r--sys-apps/man-db/man-db-2.5.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/sys-apps/man-db/man-db-2.5.3.ebuild b/sys-apps/man-db/man-db-2.5.3.ebuild
deleted file mode 100644
index abd1361..0000000
--- a/sys-apps/man-db/man-db-2.5.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.5.3.ebuild,v 1.2 2008/11/17 22:43:38 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
-HOMEPAGE="http://www.nongnu.org/man-db/"
-SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="berkdb gdbm nls"
-
-RDEPEND="berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
- !sys-apps/man"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-PROVIDE="virtual/man"
-
-pkg_setup() {
- enewgroup man 15
- enewuser man 13 -1 /usr/share/man man
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed \
- -e '/directory_entry directory_table/a\
- { "ru", "UTF-8", "UTF-8" }, /* Russian */' \
- -i src/encodings.c
-}
-
-src_compile() {
- local db="gdbm"
- use berkdb && ! use gdbm && db="db"
- econf \
- --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
- $(use_enable nls) \
- --with-db=${db} \
- || die
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc README docs/{ChangeLog,HACKING,NEWS,TODO}
-}