summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/lbcore/lbcore-1.9.008.20110901.ebuild')
-rw-r--r--net-misc/lbcore/lbcore-1.9.008.20110901.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/lbcore/lbcore-1.9.008.20110901.ebuild b/net-misc/lbcore/lbcore-1.9.008.20110901.ebuild
new file mode 100644
index 0000000..3d9180a
--- /dev/null
+++ b/net-misc/lbcore/lbcore-1.9.008.20110901.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+WEBAPP_MANUAL_SLOT="yes"
+inherit versionator webapp depend.php
+
+DATESTAMP="-$(get_version_component_range 4)"
+MY_PV=$(get_version_component_range 1-2)-$(get_version_component_range 3)
+MY_P="LBcore-${MY_PV}-Linux_x86_64${DATESTAMP}.tar.gz"
+
+DESCRIPTION="lanbilling - billing system for internet/telephony service providers"
+HOMEPAGE="http://www.lanbilling.ru/"
+SRC_URI="${MY_P}"
+RESTRICT="fetch"
+echo $MY_P
+
+RESTRICT="fetch binchecks"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_install() {
+ dodir etc
+ mv etc/billing.conf.LBcore.sample "${ED}"/etc/billing.conf || die
+ rm -rf etc
+
+ pushd usr/local/billing/phpclient >/dev/null
+ webapp_src_preinst
+ mkdir admin/files
+ SERVEROWNED_LIST="$(find admin/files admin/templates -type d) admin/users_reports"
+ mv * "${ED}"${MY_HTDOCSDIR} || die
+ webapp_serverowned $(printf "${MY_HTDOCSDIR}/%s " ${SERVEROWNED_LIST})
+# webapp_configfile ${MY_HTDOCSDIR}/soap/api3.wsdl
+ webapp_src_install
+ popd >/dev/null
+
+ mv ./usr/* "${ED}"/usr || die
+
+ newinitd "${FILESDIR}/LBcore.initd" LBcore || die
+ newconfd "${FILESDIR}/LBcore.confd" LBcore || die
+
+}