summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/Manifest5
-rw-r--r--media-libs/jpeg/README14
-rw-r--r--media-libs/jpeg/files/jdhuff_add.c32
-rw-r--r--media-libs/jpeg/jpeg-6b-r7.ebuild48
4 files changed, 0 insertions, 99 deletions
diff --git a/media-libs/jpeg/Manifest b/media-libs/jpeg/Manifest
deleted file mode 100644
index df21572..0000000
--- a/media-libs/jpeg/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX jdhuff_add.c 1808 RMD160 93810fef55e020c434a58a30c13673c2f177e40f SHA1 392d31e86e1d7d61fdbead43b79aba36b2c52a82 SHA256 3ff061fe033ae4a161c89736b65d512cbf50e60215c47bb3d302d1a12047ccff
-DIST jpeg-6b-patches-1.6.tar.bz2 22573 RMD160 21290e71c116d8e543737ffd5e26b96f34e30f93 SHA1 b66629ad0380a318442be5b5b4ba945bf98035ff SHA256 23a07581f336a1e8c33f0efdb4b3ef728fe278459811b3b89258f8525dbbbcca
-DIST jpegsrc.v6b.tar.gz 613261 RMD160 18892206014fbb8cae2a44e281f4ed53feaf7882 SHA1 7079f0d6c42fad0cfba382cf6ad322add1ace8f9 SHA256 75c3ec241e9996504fe02a9ed4d12f16b74ade713972f3db9e65ce95cd27e35d
-EBUILD jpeg-6b-r7.ebuild 1281 RMD160 1df1fa2f54f7bf2c5303520e6dfedb9f22c8b4b4 SHA1 4eb34e6c2b8f8c24bad5cb3f04ee3a9667555b53 SHA256 a5786a5e3ded173453a0440533c8f45fa9f3657306a049e04ab846a87c50fb1f
-MISC README 759 RMD160 540dab2a48f8be186900f91a3af3cfa6bd6e3c63 SHA1 a8dfd5db327b7e403b55c606881cbe2d67876403 SHA256 0e9af210899d01bff08c8f03020855b55c211cbcc9ffc6e9249ebb0693ac762c
diff --git a/media-libs/jpeg/README b/media-libs/jpeg/README
deleted file mode 100644
index b017aa0..0000000
--- a/media-libs/jpeg/README
+++ /dev/null
@@ -1,14 +0,0 @@
-jpeg with patch (jdhuff_add.c) from libtiff to enable old jpeg support. I
-though this helps me to read M$ tiff files, but I was wrong. Even after
-patching I receive the following error:
-
-convert: some.tif: unknown field with tag 37679 (0x932f) encountered. `TIFFReadDirectory'.
-convert: some.tif: unknown field with tag 37680 (0x9330) encountered. `TIFFReadDirectory'.
-convert: some.tif: unknown field with tag 37681 (0x9331) encountered. `TIFFReadDirectory'.
-convert: Invalid YCbCr subsampling. `some.tif'.
-convert: some.tif: cannot handle zero strip size. `TIFFReadDirectory'.
-convert: missing an image filename `some.png'.
-
-
-This ebuild is based on media-libs/jpeg-6b-r8 but changed revision to smaller
-to avoid any possible or impossible updates of it...
diff --git a/media-libs/jpeg/files/jdhuff_add.c b/media-libs/jpeg/files/jdhuff_add.c
deleted file mode 100644
index 8d4221b..0000000
--- a/media-libs/jpeg/files/jdhuff_add.c
+++ /dev/null
@@ -1,32 +0,0 @@
-/*
- * BEWARE OF KLUDGE: This subroutine is a hack for decoding illegal JPEG-in-
- * TIFF encapsulations produced by Microsoft's Wang Imaging
- * for Windows application with the public-domain TIFF Library. Based upon an
- * examination of selected output files, this program apparently divides a JPEG
- * bit-stream into consecutive horizontal TIFF "strips", such that the JPEG
- * encoder's/decoder's DC coefficients for each image component are reset before
- * each "strip". Moreover, a "strip" is not necessarily encoded in a multiple
- * of 8 bits, so one must sometimes discard 1-7 bits at the end of each "strip"
- * for alignment to the next input-Byte storage boundary. IJG JPEG Library
- * decoder state is not normally exposed to client applications, so this sub-
- * routine provides the TIFF Library with a "hook" to make these corrections.
- * It should be called after "jpeg_start_decompress()" and before
- * "jpeg_finish_decompress()", just before decoding each "strip" using
- * "jpeg_read_raw_data()" or "jpeg_read_scanlines()".
- *
- * This kludge is not sanctioned or supported by the Independent JPEG Group, and
- * future changes to the IJG JPEG Library might invalidate it. Do not send bug
- * reports about this code to IJG developers. Instead, contact the author for
- * advice: Scott B. Marovich <marovich@hpl.hp.com>, Hewlett-Packard Labs, 6/01.
- */
-GLOBAL(void)
-jpeg_reset_huff_decode (register j_decompress_ptr cinfo,register float *refbw)
-{ register huff_entropy_ptr entropy = (huff_entropy_ptr)cinfo->entropy;
- register int ci = 0;
-
- /* Re-initialize DC predictions */
- do entropy->saved.last_dc_val[ci] = -refbw[ci << 1];
- while (++ci < cinfo->comps_in_scan);
- /* Discard encoded input bits, up to the next Byte boundary */
- entropy->bitstate.bits_left &= ~7;
-}
diff --git a/media-libs/jpeg/jpeg-6b-r7.ebuild b/media-libs/jpeg/jpeg-6b-r7.ebuild
deleted file mode 100644
index 9ad0b65..0000000
--- a/media-libs/jpeg/jpeg-6b-r7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r7.ebuild,v 1.15 2006/09/04 03:59:21 kumba Exp $
-
-inherit libtool eutils toolchain-funcs
-
-PATCH_VER="1.6"
-DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
-HOMEPAGE="http://www.ijg.org/"
-SRC_URI="ftp://ftp.uu.net/graphics/jpeg/${PN}src.v${PV}.tar.gz
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.5.10-r4"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- cat "${FILESDIR}/jdhuff_add.c" >> jdhuff.c || die "oldjpeg support failed."
- elibtoolize
-}
-
-src_compile() {
- tc-export CC RANLIB AR
- econf \
- --enable-shared \
- --enable-static \
- --enable-maxmem=64 \
- || die "econf failed"
- emake || die "make failed"
- emake -C "${WORKDIR}"/extra || die "make extra failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install"
- emake -C "${WORKDIR}"/extra install DESTDIR="${D}" || die "install extra"
-
- dodoc README install.doc usage.doc wizard.doc change.log \
- libjpeg.doc example.c structure.doc filelist.doc \
- coderules.doc
-}