summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-07-25 22:56:19 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-07-25 22:56:19 +0530
commitf4f06684592f74facb25d5769416449469a0f67f (patch)
tree6487cd9c4ea631708b769579fc11b0104dc2ac86 /x11-themes/moblin-cursor-theme/moblin-cursor-theme-0.3.ebuild
parentAdd net-misc/cnetworkmanager-0.8.4 (diff)
downloadnirbheek-f4f06684592f74facb25d5769416449469a0f67f.tar.gz
nirbheek-f4f06684592f74facb25d5769416449469a0f67f.tar.bz2
nirbheek-f4f06684592f74facb25d5769416449469a0f67f.zip
Add Mobline Themes
x11-themes/gtk-engines-moblin x11-themes/moblin-cursor-theme x11-themes/moblin-icon-theme
Diffstat (limited to 'x11-themes/moblin-cursor-theme/moblin-cursor-theme-0.3.ebuild')
-rw-r--r--x11-themes/moblin-cursor-theme/moblin-cursor-theme-0.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-themes/moblin-cursor-theme/moblin-cursor-theme-0.3.ebuild b/x11-themes/moblin-cursor-theme/moblin-cursor-theme-0.3.ebuild
new file mode 100644
index 0000000..f66cf36
--- /dev/null
+++ b/x11-themes/moblin-cursor-theme/moblin-cursor-theme-0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+DESCRIPTION="Mobline cursor theme"
+HOMEPAGE="http://git.moblin.org/cgit.cgi/moblin-icon-theme/"
+SRC_URI="http://git.moblin.org/cgit.cgi/${PN}/snapshot/${P}.tar.bz2"
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+x11-apps/xcursorgen"
+
+src_compile() {
+ cd pngs && ./make.sh
+}
+
+src_install() {
+ cd "${S}"
+ insinto /usr/share/cursors/xorg-x11/${PN}
+ doins -r xcursors
+}
+
+pkg_postinst() {
+ elog "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ elog "and add the following line:"
+ elog "Xcursor.theme: ${PN}"
+ elog
+ elog "You can change the size by adding a line like:"
+ elog "Xcursor.size: 48"
+ elog
+ elog "Also, to globally use this set of mouse cursors edit the file:"
+ elog " /usr/share/cursors/xorg-x11/default/index.theme"
+ elog "and change the line:"
+ elog " Inherits=[current setting]"
+ elog "to"
+ elog " Inherits=${PN}"
+ elog
+ elog "Note this will be overruled by a user's ~/.Xdefaults file."
+ elog
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+}