summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/mpi-dotnet/files')
-rw-r--r--sys-cluster/mpi-dotnet/files/Makefile.am.patch22
-rw-r--r--sys-cluster/mpi-dotnet/files/Unsafe.pl.patch11
-rw-r--r--sys-cluster/mpi-dotnet/files/configure.ac.patch22
3 files changed, 55 insertions, 0 deletions
diff --git a/sys-cluster/mpi-dotnet/files/Makefile.am.patch b/sys-cluster/mpi-dotnet/files/Makefile.am.patch
new file mode 100644
index 0000000..195ea4c
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/files/Makefile.am.patch
@@ -0,0 +1,22 @@
+--- mpi.net-1.0.0.orig/MPI/Makefile.am 2009-02-03 23:55:47.000000000 +0100
++++ mpi.net-1.0.0/MPI/Makefile.am 2009-02-03 23:56:18.000000000 +0100
+@@ -16,8 +16,8 @@
+ endif
+
+ SOURCES=$(srcdir)/Attribute.cs \
+- $(srcdir)/CartesianCommunicator.cs \
+- $(srcdir)/Communicator.cs \
++ $(srcdir)/CartesianCommunicator.cs \
++ $(srcdir)/Communicator.cs \
+ $(srcdir)/Comparison.cs \
+ $(srcdir)/DatatypeCache.cs \
+ $(srcdir)/Environment.cs \
+@@ -31,7 +31,7 @@
+ $(srcdir)/RequestList.cs \
+ $(srcdir)/Status.cs \
+ $(srcdir)/TagAllocator.cs \
+- $(srcdir)/TopologicalCommunicator.cs \
++ $(srcdir)/TopologicalCommunicator.cs \
+ $(srcdir)/UnmanagedMemoryStream.cs
+
+ # We want to install directly into /lib, but we can't write lib_SCRIPTS
diff --git a/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch b/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch
new file mode 100644
index 0000000..3f28c2a
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch
@@ -0,0 +1,11 @@
+--- mpi.net-1.0.0.orig/MPI/Unsafe.pl 2009-02-03 23:55:48.000000000 +0100
++++ mpi.net-1.0.0/MPI/Unsafe.pl 2009-02-07 08:24:01.000000000 +0100
+@@ -96,7 +96,7 @@
+ }
+
+ # Grab the command-line arguments
+-$mpi_header=shift @ARGV;
++$mpi_header = (@ARGV > 3) ? shift @ARGV : "/usr/include/mpi.h";
+ $unsafe_input = shift @ARGV;
+ $unsafe_output = shift @ARGV;
+ $cbridge_output = shift @ARGV;
diff --git a/sys-cluster/mpi-dotnet/files/configure.ac.patch b/sys-cluster/mpi-dotnet/files/configure.ac.patch
new file mode 100644
index 0000000..2c69aa1
--- /dev/null
+++ b/sys-cluster/mpi-dotnet/files/configure.ac.patch
@@ -0,0 +1,22 @@
+--- mpi.net-1.0.0.orig/configure.ac 2009-02-03 23:55:46.000000000 +0100
++++ mpi.net-1.0.0/configure.ac 2009-02-06 21:59:21.000000000 +0100
+@@ -202,9 +202,16 @@
+ AM_CONDITIONAL(MPINET_CBRIDGE, test "$need_cbridge" = "yes")
+
+ dnl Variable substitutions
+-AC_SUBST(MCS ILASM MONO MPIEXEC PERL
+- CSHARP_FLAGS CSHARP_DEFINES MPI_HEADER
+- MPI_SHARED_LIB_NAME MPI_FUNC_PREFIX)
++AC_SUBST(MCS)
++AC_SUBST(ILASM)
++AC_SUBST(MONO)
++AC_SUBST(MPIEXEC)
++AC_SUBST(PERL)
++AC_SUBST(CSHARP_FLAGS)
++AC_SUBST(CSHARP_DEFINES)
++AC_SUBST(MPI_HEADER)
++AC_SUBST(MPI_SHARED_LIB_NAME)
++AC_SUBST(MPI_FUNC_PREFIX)
+
+ AC_CONFIG_FILES([MPI/MPI.dll.config Tests/runtest.sh],[],[])
+