summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libX11/libX11-1.2.1.ebuild')
-rw-r--r--x11-libs/libX11/libX11-1.2.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/x11-libs/libX11/libX11-1.2.1.ebuild b/x11-libs/libX11/libX11-1.2.1.ebuild
deleted file mode 100644
index c9a04f0..0000000
--- a/x11-libs/libX11/libX11-1.2.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.5.ebuild,v 1.1 2008/09/06 06:56:34 dberkholz Exp $
-
-# Must be before x-modular eclass is inherited
-#SNAPSHOT="yes"
-
-EAPI="1"
-
-inherit x-modular toolchain-funcs flag-o-matic
-
-DESCRIPTION="X.Org X11 library"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="ipv6 +xcb"
-
-RDEPEND=">=x11-libs/xtrans-1.2.3
- x11-proto/kbproto
- >=x11-proto/xproto-7.0.15
- xcb? ( >=x11-libs/libxcb-1.2 )
- !xcb? (
- x11-libs/libXau
- x11-libs/libXdmcp
- )"
-DEPEND="${RDEPEND}
- x11-proto/xf86bigfontproto
- x11-proto/bigreqsproto
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xcmiscproto
- >=x11-misc/util-macros-1.2.1"
-
-pkg_setup() {
- CONFIGURE_OPTIONS="$(use_enable ipv6)
- $(use_with xcb)"
- # xorg really doesn't like xlocale disabled.
- # $(use_enable nls xlocale)
-}
-
-src_compile() {
- x-modular_src_configure
- # [Cross-Compile Love] Disable {C,LD}FLAGS and redefine CC= for 'makekeys'
- ( filter-flags -m* ; cd src/util && make CC=$(tc-getBUILD_CC) CFLAGS="${CFLAGS}" LDFLAGS="" clean all)
- x-modular_src_make
-}