summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-11 12:34:42 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-11 12:34:42 +0000
commit582c1a7bd59be044f804bd74da0ff58bdd15767c (patch)
tree0910990fc7987a0512fd70aabc54567e4a3e9b98 /dev-python
downloadliquidx-582c1a7bd59be044f804bd74da0ff58bdd15767c.tar.gz
liquidx-582c1a7bd59be044f804bd74da0ff58bdd15767c.tar.bz2
liquidx-582c1a7bd59be044f804bd74da0ff58bdd15767c.zip
syncing personal repository into overlay
svn path=/; revision=2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/amara/Manifest2
-rw-r--r--dev-python/amara/amara-1.0_beta2.ebuild30
-rw-r--r--dev-python/amara/files/digest-amara-1.0_beta21
-rw-r--r--dev-python/flup/Manifest4
-rw-r--r--dev-python/flup/files/digest-flup-0.18271
-rw-r--r--dev-python/flup/files/digest-flup-0.18371
-rw-r--r--dev-python/flup/flup-0.1827.ebuild20
-rw-r--r--dev-python/flup/flup-0.1837.ebuild20
-rw-r--r--dev-python/json-py/Manifest2
-rw-r--r--dev-python/json-py/files/digest-json-py-3.41
-rw-r--r--dev-python/json-py/json-py-3.4.ebuild32
-rw-r--r--dev-python/openglcontext/Manifest2
-rw-r--r--dev-python/openglcontext/files/digest-openglcontext-2.0.0_rc11
-rw-r--r--dev-python/openglcontext/openglcontext-2.0.0_rc1.ebuild26
-rw-r--r--dev-python/pyrxp/Manifest2
-rw-r--r--dev-python/pyrxp/files/digest-pyrxp-1.05_pre200504271
-rw-r--r--dev-python/pyrxp/pyrxp-1.05_pre20050427.ebuild28
-rw-r--r--dev-python/python-eclass-test/python-eclass-test-0.1.ebuild39
-rw-r--r--dev-python/python-mcrypt/Manifest2
-rw-r--r--dev-python/python-mcrypt/files/digest-python-mcrypt-1.11
-rw-r--r--dev-python/python-mcrypt/python-mcrypt-1.1.ebuild18
21 files changed, 234 insertions, 0 deletions
diff --git a/dev-python/amara/Manifest b/dev-python/amara/Manifest
new file mode 100644
index 0000000..2e7244c
--- /dev/null
+++ b/dev-python/amara/Manifest
@@ -0,0 +1,2 @@
+MD5 31f5e549b81047b31196fe00a1f45566 amara-1.0_beta2.ebuild 657
+MD5 4cc5af71508d4506e229ca8680f9fb2c files/digest-amara-1.0_beta2 63
diff --git a/dev-python/amara/amara-1.0_beta2.ebuild b/dev-python/amara/amara-1.0_beta2.ebuild
new file mode 100644
index 0000000..a158f05
--- /dev/null
+++ b/dev-python/amara/amara-1.0_beta2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Bug: http://bugs.gentoo.org/show_bug.cgi?id=112117
+
+inherit distutils
+
+MY_P=${P/amara/Amara}
+MY_P=${MY_P/_beta/b}
+DESCRIPTION="A collection of Pythonic tools for XML data binding built on 4Suite"
+SRC_URI="http://uche.ogbuji.net/uche.ogbuji.net/tech/4Suite/amara/${MY_P}.tar.bz2"
+HOMEPAGE="http://uche.ogbuji.net/uche.ogbuji.net/tech/4Suite/amara/"
+
+DEPEND=">=dev-lang/python-2.3
+>=dev-python/4suite-1.0_alpha4"
+
+IUSE=""
+SLOT="0"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+
+PYTHON_MODNAME=Amara
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ doins -r demo test
+}
diff --git a/dev-python/amara/files/digest-amara-1.0_beta2 b/dev-python/amara/files/digest-amara-1.0_beta2
new file mode 100644
index 0000000..44e4c66
--- /dev/null
+++ b/dev-python/amara/files/digest-amara-1.0_beta2
@@ -0,0 +1 @@
+MD5 9f2794a8b37d6c41d35815876f59cb22 Amara-1.0b2.tar.bz2 70171
diff --git a/dev-python/flup/Manifest b/dev-python/flup/Manifest
new file mode 100644
index 0000000..ee9c708
--- /dev/null
+++ b/dev-python/flup/Manifest
@@ -0,0 +1,4 @@
+MD5 01cffd4ce0f367afcd19ebe6b0989882 files/digest-flup-0.1827 61
+MD5 69756f79ac54ab2f93889f36effd1b3f files/digest-flup-0.1837 61
+MD5 a96ada0b54b08511a9872be868004b54 flup-0.1827.ebuild 558
+MD5 a96ada0b54b08511a9872be868004b54 flup-0.1837.ebuild 558
diff --git a/dev-python/flup/files/digest-flup-0.1827 b/dev-python/flup/files/digest-flup-0.1827
new file mode 100644
index 0000000..e4b8a73
--- /dev/null
+++ b/dev-python/flup/files/digest-flup-0.1827
@@ -0,0 +1 @@
+MD5 37d310a7ce3f4ce715fee1a25fb6a83e flup-r1827.tar.gz 54886
diff --git a/dev-python/flup/files/digest-flup-0.1837 b/dev-python/flup/files/digest-flup-0.1837
new file mode 100644
index 0000000..b40bf19
--- /dev/null
+++ b/dev-python/flup/files/digest-flup-0.1837
@@ -0,0 +1 @@
+MD5 860edb0068a66ba067700bd4632536dd flup-r1837.tar.gz 55358
diff --git a/dev-python/flup/flup-0.1827.ebuild b/dev-python/flup/flup-0.1827.ebuild
new file mode 100644
index 0000000..3b989bc
--- /dev/null
+++ b/dev-python/flup/flup-0.1827.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cjkcodecs/cjkcodecs-1.1.1.ebuild,v 1.4 2005/03/04 21:31:57 kito Exp $
+
+# http://bugs.gentoo.org/show_bug.cgi?id=100784
+
+inherit distutils
+
+REV=${PV/0./}
+DESCRIPTION="Python implementation of the WSGI and FastCGI interfaces"
+HOMEPAGE="http://www.saddi.com/software/flup/"
+SRC_URI="http://www.saddi.com/software/flup/dist/${PN}-r${REV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4"
+S=${WORKDIR}/${PN}-r${REV}
diff --git a/dev-python/flup/flup-0.1837.ebuild b/dev-python/flup/flup-0.1837.ebuild
new file mode 100644
index 0000000..3b989bc
--- /dev/null
+++ b/dev-python/flup/flup-0.1837.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cjkcodecs/cjkcodecs-1.1.1.ebuild,v 1.4 2005/03/04 21:31:57 kito Exp $
+
+# http://bugs.gentoo.org/show_bug.cgi?id=100784
+
+inherit distutils
+
+REV=${PV/0./}
+DESCRIPTION="Python implementation of the WSGI and FastCGI interfaces"
+HOMEPAGE="http://www.saddi.com/software/flup/"
+SRC_URI="http://www.saddi.com/software/flup/dist/${PN}-r${REV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4"
+S=${WORKDIR}/${PN}-r${REV}
diff --git a/dev-python/json-py/Manifest b/dev-python/json-py/Manifest
new file mode 100644
index 0000000..45d167a
--- /dev/null
+++ b/dev-python/json-py/Manifest
@@ -0,0 +1,2 @@
+MD5 8c26bb36f1d924b83efc72d872455aa9 files/digest-json-py-3.4 59
+MD5 ab13cdc8afb89057dd7d67fa3a2556c4 json-py-3.4.ebuild 506
diff --git a/dev-python/json-py/files/digest-json-py-3.4 b/dev-python/json-py/files/digest-json-py-3.4
new file mode 100644
index 0000000..fab7294
--- /dev/null
+++ b/dev-python/json-py/files/digest-json-py-3.4
@@ -0,0 +1 @@
+MD5 921ebfede886a10ff32d6d4b4e216f8f json-py-3_4.zip 20111
diff --git a/dev-python/json-py/json-py-3.4.ebuild b/dev-python/json-py/json-py-3.4.ebuild
new file mode 100644
index 0000000..1dada43
--- /dev/null
+++ b/dev-python/json-py/json-py-3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygoogle/pygoogle-0.6.ebuild,v 1.4 2005/07/02 16:48:16 fserb Exp $
+
+# http://bugs.gentoo.org/show_bug.cgi?id=112451
+
+inherit eutils distutils
+
+MY_PV=${PV/./_}
+DESCRIPTION="JSON reader/writer for python."
+SRC_URI="mirror://sourceforge/json-py/${PN}-${MY_PV}.zip"
+HOMEPAGE="http://sourceforge.net/projects/json-py/"
+
+IUSE=""
+SLOT="0"
+LICENSE="PYTHON"
+KEYWORDS="~x86 ~ppc-macos ~amd64"
+
+DEPEND="virtual/python"
+S=${WORKDIR}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ cd ${S}
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins json.py minjson.py
+ dodoc changes.txt license.txt readme.txt
+}
diff --git a/dev-python/openglcontext/Manifest b/dev-python/openglcontext/Manifest
new file mode 100644
index 0000000..485be64
--- /dev/null
+++ b/dev-python/openglcontext/Manifest
@@ -0,0 +1,2 @@
+MD5 db21adddf1385bb935e66cbde1ae9f88 files/digest-openglcontext-2.0.0_rc1 73
+MD5 ed20880d67844abf5c7736b87b7632a3 openglcontext-2.0.0_rc1.ebuild 676
diff --git a/dev-python/openglcontext/files/digest-openglcontext-2.0.0_rc1 b/dev-python/openglcontext/files/digest-openglcontext-2.0.0_rc1
new file mode 100644
index 0000000..5b645ac
--- /dev/null
+++ b/dev-python/openglcontext/files/digest-openglcontext-2.0.0_rc1
@@ -0,0 +1 @@
+MD5 1ba3b69100bbdb4f754ec10169c8074c OpenGLContext-2.0.0c1.tar.gz 864024
diff --git a/dev-python/openglcontext/openglcontext-2.0.0_rc1.ebuild b/dev-python/openglcontext/openglcontext-2.0.0_rc1.ebuild
new file mode 100644
index 0000000..76d29c6
--- /dev/null
+++ b/dev-python/openglcontext/openglcontext-2.0.0_rc1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+MY_PN="OpenGLContext"
+MY_PV="2.0.0c1" # change when version has an a1 or similar extension
+
+DESCRIPTION="Testing and demonstration contexts for PyOpenGL"
+HOMEPAGE="http://pyopengl.sourceforge.net/context/"
+SRC_URI="mirror://sourceforge/pyopengl/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+RDEPEND="virtual/python
+ dev-python/ttfquery
+ dev-python/imaging
+ dev-python/numeric
+ dev-python/pydispatcher
+ >=dev-python/pyopengl-2.0.1.09"
+DEPEND="virtual/python"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
diff --git a/dev-python/pyrxp/Manifest b/dev-python/pyrxp/Manifest
new file mode 100644
index 0000000..a8bc210
--- /dev/null
+++ b/dev-python/pyrxp/Manifest
@@ -0,0 +1,2 @@
+MD5 07d154a8050718ec9d4cf03ed2451840 pyrxp-1.05_pre20050427.ebuild 625
+MD5 de43569a8a2c2abc0c2f6aad8131d555 files/digest-pyrxp-1.05_pre20050427 71
diff --git a/dev-python/pyrxp/files/digest-pyrxp-1.05_pre20050427 b/dev-python/pyrxp/files/digest-pyrxp-1.05_pre20050427
new file mode 100644
index 0000000..b025404
--- /dev/null
+++ b/dev-python/pyrxp/files/digest-pyrxp-1.05_pre20050427
@@ -0,0 +1 @@
+MD5 9280d7eb5b0bd7b8e288409619768cf6 pyrxp-1.05_pre20050427.tgz 354883
diff --git a/dev-python/pyrxp/pyrxp-1.05_pre20050427.ebuild b/dev-python/pyrxp/pyrxp-1.05_pre20050427.ebuild
new file mode 100644
index 0000000..f89b38a
--- /dev/null
+++ b/dev-python/pyrxp/pyrxp-1.05_pre20050427.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# http://bugs.gentoo.org/show_bug.cgi?id=39457
+
+inherit distutils
+
+DESCRIPTION="Python wrapper around RXP, a very fast validating XML parser"
+SRC_URI="http://dev.gentoo.org/~liquidx/snapshots/${P}.tgz"
+HOMEPAGE="http://www.reportlab.org/pyrxp.html"
+
+DEPEND="virtual/python"
+IUSE=""
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/pyRXP-${PV/_pre/-}/pyRXP
+
+src_install() {
+ distutils_src_install
+
+ dodoc docs/* README
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ doins -r test
+}
diff --git a/dev-python/python-eclass-test/python-eclass-test-0.1.ebuild b/dev-python/python-eclass-test/python-eclass-test-0.1.ebuild
new file mode 100644
index 0000000..602d2af
--- /dev/null
+++ b/dev-python/python-eclass-test/python-eclass-test-0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cjkcodecs/cjkcodecs-1.1.1.ebuild,v 1.4 2005/03/04 21:31:57 kito Exp $
+
+inherit python
+
+DESCRIPTION="Dummy Ebuild to test python"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+pkg_setup() {
+ einfo "Testing python_extract_version():"
+ __python_eclass_test
+
+ python_version
+ einfo "I think the current version of python is: ${PYVER}"
+
+ python_disable_pyc
+ if [ "x$PYTHON_DONTCOMPILE" = "x1" ]; then
+ einfo "Disabling pyc generation works!"
+ else
+ eerror "Disabling pyc generation doesn't work!"
+ fi
+
+ python_enable_pyc
+ if [ "x$PYTHON_DONTCOMPILE" = "x" ]; then
+ einfo "Enabling pyc generation works!"
+ else
+ eerror "Enabling pyc generation doesn't work!"
+ fi
+}
+
+
+
diff --git a/dev-python/python-mcrypt/Manifest b/dev-python/python-mcrypt/Manifest
new file mode 100644
index 0000000..dcf1dc3
--- /dev/null
+++ b/dev-python/python-mcrypt/Manifest
@@ -0,0 +1,2 @@
+MD5 95e5aedc6c5f824743dad08a0d8495b7 python-mcrypt-1.1.ebuild 582
+MD5 c59d000af863e84869b40f5864298e9f files/digest-python-mcrypt-1.1 68
diff --git a/dev-python/python-mcrypt/files/digest-python-mcrypt-1.1 b/dev-python/python-mcrypt/files/digest-python-mcrypt-1.1
new file mode 100644
index 0000000..b2279e3
--- /dev/null
+++ b/dev-python/python-mcrypt/files/digest-python-mcrypt-1.1
@@ -0,0 +1 @@
+MD5 0e9f7cc17545af6b51188b38984fe034 python-mcrypt-1.1.tar.gz 22708
diff --git a/dev-python/python-mcrypt/python-mcrypt-1.1.ebuild b/dev-python/python-mcrypt/python-mcrypt-1.1.ebuild
new file mode 100644
index 0000000..b1e5c91
--- /dev/null
+++ b/dev-python/python-mcrypt/python-mcrypt-1.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cjkcodecs/cjkcodecs-1.1.1.ebuild,v 1.4 2005/03/04 21:31:57 kito Exp $
+
+inherit distutils
+
+DESCRIPTION="Python interface to the mcrypt library, which provides a uniform interface to several symmetric encryption algorithms."
+HOMEPAGE="http://sourceforge.net/projects/python-mcrypt/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+dev-libs/libmcrypt"
+