summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/anjal/anjal-0.3.2.ebuild')
-rw-r--r--mail-client/anjal/anjal-0.3.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/mail-client/anjal/anjal-0.3.2.ebuild b/mail-client/anjal/anjal-0.3.2.ebuild
new file mode 100644
index 0000000..f67aacf
--- /dev/null
+++ b/mail-client/anjal/anjal-0.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit gnome2
+
+DESCRIPTION="Lightweight mail client"
+HOMEPAGE="http://live.gnome.org/Anjal"
+
+LICENSE="|| ( LGPL-2 LGPL-3 )"
+SLOT="0"
+KEYWORDS=""
+IUSE="clutter ssl webkit xulrunner"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.8
+ >=dev-libs/glib-2
+ dev-libs/libxml2
+ dev-db/sqlite:3
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2.6
+ >=gnome-extra/evolution-data-server-1.2
+ >=net-libs/libsoup-2.4:2.4
+ >=mail-client/evolution-2.29.4
+ >=gnome-extra/gtkhtml-3.14
+ sys-apps/dbus
+ clutter? ( >=media-libs/clutter-1:1.0[gtk] )
+ webkit? ( >=net-libs/webkit-gtk-1.1.12 )
+ xulrunner? ( net-libs/xulrunner )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-anerlay
+ $(use_enable clutter)
+ $(use_enable ssl nss)
+ $(use_enable ssl smime)
+ $(use_enable webkit patched-webkit)
+ $(use_enable xulrunner mozilla)"
+}