summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/freebsd-sources/files/freebsd-sources-6.0-werror.patch')
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-6.0-werror.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-6.0-werror.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-6.0-werror.patch
new file mode 100644
index 0000000..0a57905
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-6.0-werror.patch
@@ -0,0 +1,26 @@
+Index: fbsd-6/sys/conf/kern.pre.mk
+===================================================================
+--- fbsd-6.orig/sys/conf/kern.pre.mk
++++ fbsd-6/sys/conf/kern.pre.mk
+@@ -76,7 +76,7 @@ CFLAGS+= ${INCLUDES} -D_KERNEL -DHAVE_KE
+ CFLAGS+= -fno-common -finline-limit=${INLINE_LIMIT}
+ CFLAGS+= --param inline-unit-growth=100
+ CFLAGS+= --param large-function-growth=1000
+-WERROR?= -Werror
++WERROR?= -Wno-error
+ .endif
+
+ # XXX LOCORE means "don't declare C stuff" not "for locore.s".
+Index: fbsd-6/sys/conf/kmod.mk
+===================================================================
+--- fbsd-6.orig/sys/conf/kmod.mk
++++ fbsd-6/sys/conf/kmod.mk
+@@ -73,7 +73,7 @@ CFLAGS:= ${CFLAGS:C/(-x[^M^K^W]+)[MKW]+|
+ . if !empty(CFLAGS:M-O[23s]) && empty(CFLAGS:M-fno-strict-aliasing)
+ CFLAGS+= -fno-strict-aliasing
+ . endif
+-WERROR?= -Werror
++WERROR?= -Wno-error
+ .endif
+ CFLAGS+= ${WERROR}
+ CFLAGS+= -D_KERNEL