summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-plugins/files')
-rw-r--r--net-analyzer/nagios-plugins/files/nagios-plugins-1.4.10-contrib.patch43
-rw-r--r--net-analyzer/nagios-plugins/files/nagios-plugins-1.4.10-noradius.patch30
2 files changed, 73 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.10-contrib.patch b/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.10-contrib.patch
new file mode 100644
index 0000000..905f760
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.10-contrib.patch
@@ -0,0 +1,43 @@
+diff -Naur nagios-plugins-1.4.10.orig/contrib/check_dns_random.pl nagios-plugins-1.4.10/contrib/check_dns_random.pl
+--- nagios-plugins-1.4.10.orig/contrib/check_dns_random.pl 2003-01-29 06:27:20.000000000 +0100
++++ nagios-plugins-1.4.10/contrib/check_dns_random.pl 2007-09-29 10:57:38.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/perl -w
+ # ------------------------------------------------------------------------------
+ # File Name: check_dns_random.pl
+ # Author: Richard Mayhew - South Africa
+@@ -33,9 +33,9 @@
+
+ my $host = shift || &usage;
+
+-my $domainfile = "/usr/local/nagios/etc/domains.list";
++my $domainfile = "/etc/nagios/domains.list";
+ my $wc = `/usr/bin/wc -l $domainfile`;
+-my $check = "/usr/local/nagios/libexec/check_dns";
++my $check = "/usr/nagios/libexec/check_dns";
+ my $x = 0;
+ my $srv_file = "";
+ my $z = "";
+@@ -49,8 +49,7 @@
+ my @data = split(/\n/,$srv_file);
+
+ chomp $wc;
+-$wc =~ s/ //g;
+-$wc =~ s/domains//g;
++$wc =~ s/([[:digit:]]+) .*/$1/g;
+
+ $x = rand $wc;
+ ($z,$y) = split(/\./,$x);
+diff -Naur nagios-plugins-1.4.10.orig/contrib/check_linux_raid.pl nagios-plugins-1.4.10/contrib/check_linux_raid.pl
+--- nagios-plugins-1.4.10.orig/contrib/check_linux_raid.pl 2007-08-28 05:19:45.000000000 +0200
++++ nagios-plugins-1.4.10/contrib/check_linux_raid.pl 2007-09-29 10:57:50.000000000 +0200
+@@ -23,7 +23,7 @@
+ # WARNING md0 status=[UUU_U], recovery=46.4%, finish=123.0min
+
+ use strict;
+-use lib "/usr/local/nagios/libexec";
++use lib "/usr/nagios/libexec";
+ use utils qw(%ERRORS);
+
+ # die with an error if we're not on Linux
diff --git a/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.10-noradius.patch b/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.10-noradius.patch
new file mode 100644
index 0000000..6d51d7f
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/nagios-plugins-1.4.10-noradius.patch
@@ -0,0 +1,30 @@
+diff -Naur nagios-plugins-1.4.10.orig/configure.in nagios-plugins-1.4.10/configure.in
+--- nagios-plugins-1.4.10.orig/configure.in 2007-09-29 02:44:36.000000000 +0200
++++ nagios-plugins-1.4.10/configure.in 2007-09-29 11:20:19.000000000 +0200
+@@ -210,26 +210,6 @@
+ LIBS="$_SAVEDLIBS"
+ CPPFLAGS="$_SAVEDCPPFLAGS"
+
+-dnl Check for radius libraries
+-_SAVEDLIBS="$LIBS"
+-AC_CHECK_LIB(radiusclient,rc_read_config)
+-if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then
+- EXTRAS="$EXTRAS check_radius"
+- RADIUSLIBS="-lradiusclient"
+- AC_SUBST(RADIUSLIBS)
+-else
+- AC_CHECK_LIB(radiusclient-ng,rc_read_config)
+- if test "$ac_cv_lib_radiusclient_ng_rc_read_config" = "yes"; then
+- EXTRAS="$EXTRAS check_radius"
+- RADIUSLIBS="-lradiusclient-ng"
+- AC_SUBST(RADIUSLIBS)
+- else
+- AC_MSG_WARN([Skipping radius plugin])
+- AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).])
+- fi
+-fi
+-LIBS="$_SAVEDLIBS"
+-
+ dnl Check for LDAP libraries
+ _SAVEDLIBS="$LIBS"
+ AC_CHECK_LIB(ldap,main,,,-llber)