aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/mlpy/mlpy-3.5.0.ebuild')
-rw-r--r--sci-mathematics/mlpy/mlpy-3.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/mlpy/mlpy-3.5.0.ebuild b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
new file mode 100644
index 0000000..c5daf07
--- /dev/null
+++ b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit distutils
+
+DESCRIPTION="Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling"
+HOMEPAGE="https://mlpy.fbk.eu/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+RDEPEND=">=sci-libs/gsl-1.11
+ >=dev-python/numpy-1.3
+ >=sci-libs/scipy-0.7
+ >=dev-lang/python-2.6"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ pushd docs 2>/dev/null || die
+ emake html || die
+ dohtml -r build/html/*
+ popd 2>/dev/null || die
+ fi
+}