aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyalsaaudio/pyalsaaudio-0.2-r1.ebuild')
-rw-r--r--dev-python/pyalsaaudio/pyalsaaudio-0.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyalsaaudio/pyalsaaudio-0.2-r1.ebuild b/dev-python/pyalsaaudio/pyalsaaudio-0.2-r1.ebuild
new file mode 100644
index 0000000..81713d3
--- /dev/null
+++ b/dev-python/pyalsaaudio/pyalsaaudio-0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Wrappers for accessing the ALSA API from Python"
+HOMEPAGE="http://www.wilstrup.net/pyalsaaudio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="media-libs/alsa-lib"
+
+RESTRICT="mirror"
+
+# test files
+TESTFILES="mixertest.py playbacktest.py recordtest.py test.py"
+
+src_install() {
+ distutils_src_install
+ # html documentation
+ dohtml -A tex -r doc/*
+ # copy examples and test files
+ dodir /usr/share/${PN}
+ cp ${TESTFILES} ${D}/usr/share/${PN}
+}