summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/zarafa/zarafa-6.40.3.ebuild')
-rw-r--r--net-mail/zarafa/zarafa-6.40.3.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/net-mail/zarafa/zarafa-6.40.3.ebuild b/net-mail/zarafa/zarafa-6.40.3.ebuild
deleted file mode 100644
index 50d8ef9..0000000
--- a/net-mail/zarafa/zarafa-6.40.3.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-
-PHP_EXT_NAME="mapi"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-inherit eutils php-ext-base-r1
-
-DESCRIPTION="Open Source Groupware Solution"
-HOMEPAGE="http://zarafa.com/"
-SRC_URI="http://dev.gentoo.org/~dagger/files/${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="debug ldap +logrotate static"
-
-RDEPEND=">=dev-libs/libical-0.44
- =dev-cpp/libvmime-0.7.1
- >=dev-lang/php-5.2.0
- app-text/catdoc
- app-text/poppler
- dev-cpp/clucene
- dev-db/mysql
- dev-libs/libxml2
- dev-libs/openssl
- net-misc/curl
- sys-libs/e2fsprogs-libs
- sys-libs/zlib
- ldap? ( net-nds/openldap )
- logrotate? ( app-admin/logrotate )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- sys-devel/gettext"
-
-src_prepare() {
- # Fixes zarafa-server linking
- epatch "${FILESDIR}"/"${PN}"-6.40.1-uuid-link.patch
-
- # Don't install php ini file, as installation doesn't
- # respect Gentoo way of handling SAPIs
- epatch "${FILESDIR}"/"${PN}"-6.40.1-no-php-conf.patch
-}
-
-src_configure() {
- econf \
- --enable-oss \
- --disable-perl \
- --disable-testtools \
- --with-userscript-prefix=/etc/zarafa/userscripts \
- --with-quotatemplate-prefix=/etc/zarafa/quotamails \
- --with-indexerscripts-prefix=/etc/zarafa/indexerscripts \
- $(use_enable static) \
- $(use_enable debug)
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- # Install PHP module
- php-ext-base-r1_src_install
- php-ext-base-r1_addtoinifiles ";mapi.cache_max_sessions" "128"
- php-ext-base-r1_addtoinifiles ";mapi.cache_lifetime" "300"
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/zarafa.logrotate zarafa || die "Failed to install logrotate"
- fi
-
- insinto /etc/zarafa
- doins "${S}"/installer/linux/*.cfg || die "Failed to install config files"
-
- dodir /var/log/zarafa
- keepdir /var/log/zarafa
-
- newinitd "${FILESDIR}"/zarafa-gateway.rc6 zarafa-gateway
- newinitd "${FILESDIR}"/zarafa-ical.rc6 zarafa-ical
- newinitd "${FILESDIR}"/zarafa-indexer.rc6 zarafa-indexer
- newinitd "${FILESDIR}"/zarafa-monitor.rc6 zarafa-monitor
- newinitd "${FILESDIR}"/zarafa-server.rc6 zarafa-server
- newinitd "${FILESDIR}"/zarafa-spooler.rc6 zarafa-spooler
-
-}