summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2021-02-28 16:38:45 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2021-02-28 16:38:45 +0300
commit20e382ace3302c875f6d98629658e5c424700537 (patch)
tree4901d8dc6c75874f8849f977d179343daef3784f
parentdistcc: fix some qa issues (diff)
downloadbircoph-20e382ace3302c875f6d98629658e5c424700537.tar.gz
bircoph-20e382ace3302c875f6d98629658e5c424700537.tar.bz2
bircoph-20e382ace3302c875f6d98629658e5c424700537.zip
dev-python/pyDes: update python versions
pyDes works fine with any python version available, update PYTHON_COMPAT to recent versions. Bug: https://bugs.gentoo.org/772596 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--dev-python/pyDes/pyDes-2.0.1-r2.ebuild (renamed from dev-python/pyDes/pyDes-2.0.1-r1.ebuild)7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/pyDes/pyDes-2.0.1-r1.ebuild b/dev-python/pyDes/pyDes-2.0.1-r2.ebuild
index effc9b0..a9aec03 100644
--- a/dev-python/pyDes/pyDes-2.0.1-r1.ebuild
+++ b/dev-python/pyDes/pyDes-2.0.1-r2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="Python implementation of DES an Triple-DES algorithms"