summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ross <aross@gentoo.org>2006-08-16 08:45:07 +0000
committerAndrew Ross <aross@gentoo.org>2006-08-16 08:45:07 +0000
commit871b582904432581df8430e87108773feacc4c81 (patch)
treecb767275aef6156fe0af50e25613454b4221725e
parentBetter to keep these out of the overlay - don't want bugs filed with the Xen ... (diff)
downloadaross-871b582904432581df8430e87108773feacc4c81.tar.gz
aross-871b582904432581df8430e87108773feacc4c81.tar.bz2
aross-871b582904432581df8430e87108773feacc4c81.zip
Add xen-3.0.2-r1 with swegener's fix from bugzilla bug #143999
svn path=/; revision=4
-rw-r--r--app-emulation/xen/Manifest7
-rw-r--r--app-emulation/xen/files/digest-xen-3.0.2-r13
-rw-r--r--app-emulation/xen/xen-3.0.2-r1.ebuild107
3 files changed, 117 insertions, 0 deletions
diff --git a/app-emulation/xen/Manifest b/app-emulation/xen/Manifest
index 7004059..efb64ce 100644
--- a/app-emulation/xen/Manifest
+++ b/app-emulation/xen/Manifest
@@ -23,6 +23,10 @@ MD5 a3c0c26c30ce1271b439661b68ca9e74 files/xendomains-init 1671
RMD160 e2dbb7b4da5ff8be60532e5a393988f47f28c036 files/xendomains-init 1671
SHA256 19aac7da0ba103ae800ed10b7d151912b3a9476edf63c3651073a197ea291e49 files/xendomains-init 1671
DIST xen-3.0.2-src.tgz 4933621 RMD160 34e4431a981891319f8a5ea0c3f604e7d8d7d7af SHA1 b7e797048b516f8b385afd3da9ae2eded1b8033a SHA256 f18ffab16a457fa721d11933c75f8288f6958c88c2669857c7c11d5107ba2951
+EBUILD xen-3.0.2-r1.ebuild 2814 RMD160 01a8bb25e0fe3e5ec01dd1a7960824292c67f41b SHA1 abef50f1c222ed39501779f8ec6329e6d3f016f9 SHA256 1da738c97eed2919213cc381f526dea3ec6f7b41ff1a62e67dd91927f1e2f6c9
+MD5 d64d41ced637db24474ffd7b5e583344 xen-3.0.2-r1.ebuild 2814
+RMD160 01a8bb25e0fe3e5ec01dd1a7960824292c67f41b xen-3.0.2-r1.ebuild 2814
+SHA256 1da738c97eed2919213cc381f526dea3ec6f7b41ff1a62e67dd91927f1e2f6c9 xen-3.0.2-r1.ebuild 2814
EBUILD xen-3.0.2.ebuild 2593 RMD160 b39ee760f76df5a62c1bc259b0b87eba40a4b336 SHA1 4d3efa5f481f588360205fd9e086e2890e2af8fa SHA256 d8c525fde493ac1110957d5ff13fbb3bd4dd57ebe2ab5605192176ddc4b055b3
MD5 c8f3f22e2059173683d3d5495c7e8f04 xen-3.0.2.ebuild 2593
RMD160 b39ee760f76df5a62c1bc259b0b87eba40a4b336 xen-3.0.2.ebuild 2593
@@ -30,3 +34,6 @@ SHA256 d8c525fde493ac1110957d5ff13fbb3bd4dd57ebe2ab5605192176ddc4b055b3 xen-3.0.
MD5 6618adc624bc8ab64af0f4555c33529a files/digest-xen-3.0.2 235
RMD160 ad3a1d2a82c40b0bca653431c2d7964809580e5e files/digest-xen-3.0.2 235
SHA256 274536fc8a3cb10fda114e533062b0dbddcda4ae15f52033a39b85785b221794 files/digest-xen-3.0.2 235
+MD5 6618adc624bc8ab64af0f4555c33529a files/digest-xen-3.0.2-r1 235
+RMD160 ad3a1d2a82c40b0bca653431c2d7964809580e5e files/digest-xen-3.0.2-r1 235
+SHA256 274536fc8a3cb10fda114e533062b0dbddcda4ae15f52033a39b85785b221794 files/digest-xen-3.0.2-r1 235
diff --git a/app-emulation/xen/files/digest-xen-3.0.2-r1 b/app-emulation/xen/files/digest-xen-3.0.2-r1
new file mode 100644
index 0000000..724d092
--- /dev/null
+++ b/app-emulation/xen/files/digest-xen-3.0.2-r1
@@ -0,0 +1,3 @@
+MD5 544eab940a0734a55459d648e5c3b224 xen-3.0.2-src.tgz 4933621
+RMD160 34e4431a981891319f8a5ea0c3f604e7d8d7d7af xen-3.0.2-src.tgz 4933621
+SHA256 f18ffab16a457fa721d11933c75f8288f6958c88c2669857c7c11d5107ba2951 xen-3.0.2-src.tgz 4933621
diff --git a/app-emulation/xen/xen-3.0.2-r1.ebuild b/app-emulation/xen/xen-3.0.2-r1.ebuild
new file mode 100644
index 0000000..9624d65
--- /dev/null
+++ b/app-emulation/xen/xen-3.0.2-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.2.ebuild,v 1.6 2006/08/04 15:09:42 chrb Exp $
+
+inherit mount-boot flag-o-matic
+
+DESCRIPTION="The Xen virtual machine monitor"
+HOMEPAGE="http://xen.sourceforge.net"
+if [[ ${PV} == *_p* ]]; then
+ XEN_UNSTABLE="xen-unstable-${PV#*_p}"
+ SRC_URI="mirror://gentoo/${XEN_UNSTABLE}.tar.bz2"
+ S="${WORKDIR}/${XEN_UNSTABLE}"
+else
+ SRC_URI="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/${P}-src.tgz"
+ S="${WORKDIR}/xen-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug custom-cflags pae hardened"
+
+DEPEND="sys-devel/dev86"
+RDEPEND=""
+
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ -z ${XEN_TARGET_ARCH} ]] ; then
+ if use x86 ; then
+ export XEN_TARGET_ARCH="x86_32"
+ elif use amd64 ; then
+ export XEN_TARGET_ARCH="x86_64"
+ else
+ die "Unsupported architecture!"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+ if use hardened; then
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}"-3.0.2-nopiessp.patch
+ fi
+}
+
+src_compile() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ if use custom-cflags; then
+ filter-flags -fPIE -fstack-protector
+ else
+ unset CFLAGS
+ fi
+
+ # Send raw LDFLAGS so that --as-needed works
+ emake LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+}
+
+src_install() {
+ local myopt
+ use pae && myopt="${myopt} pae=y"
+
+ make DESTDIR="${D}" ${myopt} install-xen \
+ || die "install failed"
+
+ # for upstream change tracking
+ if [[ -n ${XEN_UNSTABLE} ]]; then
+ dodoc "${S}"/XEN-VERSION
+ fi
+}
+
+pkg_postinst() {
+ einfo "Please visit the Xen and Gentoo wiki:"
+ einfo "http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+
+ echo
+ einfo "Note: xen tools have been moved to app-emulation/xen-tools;"
+ einfo "you need to install that package to manage your domains."
+
+ if [[ -n ${XEN_UNSTABLE} ]]; then
+ echo
+ einfo "This is a snapshot of the xen-unstable tree."
+ einfo "Please report bugs in xen itself (and not the packaging) to"
+ einfo "bugzilla.xensource.com"
+ fi
+
+ if use pae; then
+ echo
+ einfo "This is a PAE build of Xen. It will *only* boot PAE kernels!"
+ fi
+}