summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/libxfcegui4/libxfcegui4-4.1.99.2.ebuild')
-rw-r--r--xfce-base/libxfcegui4/libxfcegui4-4.1.99.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-base/libxfcegui4/libxfcegui4-4.1.99.2.ebuild b/xfce-base/libxfcegui4/libxfcegui4-4.1.99.2.ebuild
new file mode 100644
index 000000000000..c6eff221318f
--- /dev/null
+++ b/xfce-base/libxfcegui4/libxfcegui4-4.1.99.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/libxfcegui4-4.1.99.2.ebuild,v 1.1 2004/12/13 20:31:56 bcowan Exp $
+
+DESCRIPTION="Libraries for Xfce 4"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+RDEPEND="virtual/x11
+ >=x11-libs/gtk+-2.2*
+ dev-libs/libxml2
+ x11-libs/startup-notification
+ >=dev-libs/dbh-1.0.20
+ =xfce-base/libxfce4util-${PV}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ `use_enable xinerama` || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog* AUTHORS README*
+}