summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/libxfce4menu/libxfce4menu-4.6.2.ebuild')
-rw-r--r--xfce-base/libxfce4menu/libxfce4menu-4.6.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-base/libxfce4menu/libxfce4menu-4.6.2.ebuild b/xfce-base/libxfce4menu/libxfce4menu-4.6.2.ebuild
new file mode 100644
index 000000000000..1a45bdc9f788
--- /dev/null
+++ b/xfce-base/libxfce4menu/libxfce4menu-4.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4menu/libxfce4menu-4.6.2.ebuild,v 1.1 2010/05/22 15:27:30 angelos Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="a freedesktop.org compliant menu library for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/libraries"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2"
+
+LICENSE="LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfce4util-4.6"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ --disable-static
+ $(xfconf_use_debug)
+ --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}