summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qtcurve/ChangeLog7
-rw-r--r--x11-themes/qtcurve/qtcurve-0.61.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-themes/qtcurve/ChangeLog b/x11-themes/qtcurve/ChangeLog
index ef1bdf7db866..92c22c0efef5 100644
--- a/x11-themes/qtcurve/ChangeLog
+++ b/x11-themes/qtcurve/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/ChangeLog,v 1.50 2009/02/24 23:06:49 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/ChangeLog,v 1.51 2009/03/02 13:27:45 yngwin Exp $
+
+*qtcurve-0.61.4 (02 Mar 2009)
+
+ 02 Mar 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-0.61.4.ebuild:
+ Version bump
*qtcurve-0.61.2 (24 Feb 2009)
diff --git a/x11-themes/qtcurve/qtcurve-0.61.4.ebuild b/x11-themes/qtcurve/qtcurve-0.61.4.ebuild
new file mode 100644
index 000000000000..affea3903347
--- /dev/null
+++ b/x11-themes/qtcurve/qtcurve-0.61.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/qtcurve-0.61.4.ebuild,v 1.1 2009/03/02 13:27:45 yngwin Exp $
+
+EAPI=1
+
+# Order is important, so we get src_compile from cmake-utils.
+inherit kde-functions qt3 cmake-utils
+
+MY_P=${P/qtcurve/QtCurve-KDE3}
+
+DESCRIPTION="A set of widget styles for KDE3 based apps, also available for GTK2 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qt:3"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4"
+
+need-kde 3.5
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+pkg_postinst() {
+ buildsycoca
+}
+
+pkg_postrm() {
+ buildsycoca
+}