summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild')
-rw-r--r--x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild31
1 files changed, 11 insertions, 20 deletions
diff --git a/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild b/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild
index 9cc9f1525837..39d9ca5acdeb 100644
--- a/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild
+++ b/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild,v 1.12 2010/01/06 19:42:30 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r1.ebuild,v 1.13 2010/02/24 14:12:14 ssuominen Exp $
+EAPI=2
inherit eutils gnome2-utils
-DESCRIPTION="This is an extension to the Tango Icon Theme. It includes Tango icons for iPod Digital Audio Player (DAP) devices and the Dell Pocket DJ DAP."
+DESCRIPTION="Tango icons for iPod Digital Audio Player (DAP) devices and the Dell Pocket DJ DAP."
HOMEPAGE="http://tango.freedesktop.org"
SRC_URI="http://tango.freedesktop.org/releases/${P}.tar.gz"
@@ -16,33 +17,23 @@ IUSE="png"
RESTRICT="binchecks strip"
RDEPEND=">=x11-misc/icon-naming-utils-0.6.0
- media-gfx/imagemagick
>=gnome-base/librsvg-2.12.3
>=x11-themes/tango-icon-theme-0.8"
DEPEND="${RDEPEND}
+ media-gfx/imagemagick[png?]
dev-util/pkgconfig"
-pkg_setup() {
- if use png && ! built_with_use media-gfx/imagemagick png; then
- die "Build media-gfx/imagemagick with USE=png."
- fi
-}
-
-src_compile() {
- econf $(use_enable png png-creation) \
+src_configure() {
+ econf \
+ $(use_enable png png-creation) \
$(use_enable png icon-framing)
- emake || die "emake failed."
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README
}
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }