summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/conectiva-crystal/conectiva-crystal-120902.ebuild')
-rw-r--r--x11-themes/conectiva-crystal/conectiva-crystal-120902.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/conectiva-crystal/conectiva-crystal-120902.ebuild b/x11-themes/conectiva-crystal/conectiva-crystal-120902.ebuild
new file mode 100644
index 000000000000..7e3b48bcd8b1
--- /dev/null
+++ b/x11-themes/conectiva-crystal/conectiva-crystal-120902.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/conectiva-crystal/conectiva-crystal-120902.ebuild,v 1.1 2002/12/09 19:34:03 satai Exp $
+inherit kde # not kde-base since we don't need c++ deps
+
+need-kde 3
+
+S="${WORKDIR}/crystal"
+DESCRIPTION="Conectiva Crystal - Icon theme. WARNING: already included in >=kde-3.1."
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/${P}.tar.gz"
+HOMEPAGE="http://www.conectiva.com.br"
+KEYWORDS="x86 alpha"
+SLOT="0"
+LICENSE="as-is"
+
+# stripping hangs and we've no binaries
+RESTRICT="$RESTRICT nostrip"
+
+src_compile() {
+
+ cd ${S}
+ sed "s/Name=Conectiva Crystal .*/Name=Conectiva Crystal Snapshot ${PV}/" index.desktop > index.temp
+ mv index.temp index.desktop
+ return 1
+}
+
+src_install(){
+
+ cd ${S}
+ dodir $PREFIX/share/icons/
+ cp -rf ${S} ${D}/${PREFIX}/share/icons/Crystal-${PV}
+
+}