summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xstroke/ChangeLog7
-rw-r--r--x11-misc/xstroke/files/xstroke-0.6-underlinking.patch11
-rw-r--r--x11-misc/xstroke/xstroke-0.6-r1.ebuild39
3 files changed, 38 insertions, 19 deletions
diff --git a/x11-misc/xstroke/ChangeLog b/x11-misc/xstroke/ChangeLog
index 2a6601537dcc..1d8256e3110d 100644
--- a/x11-misc/xstroke/ChangeLog
+++ b/x11-misc/xstroke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xstroke
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/ChangeLog,v 1.29 2012/05/05 04:53:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/ChangeLog,v 1.30 2012/09/12 01:51:34 jer Exp $
+
+ 12 Sep 2012; Jeroen Roovers <jer@gentoo.org> xstroke-0.6-r1.ebuild,
+ +files/xstroke-0.6-underlinking.patch:
+ Fix underlinking, missing depencies by Michael Palimaka (kensington) (bug
+ #370011).
05 May 2012; Jeff Horelick <jdhore@gentoo.org> xstroke-0.6-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-misc/xstroke/files/xstroke-0.6-underlinking.patch b/x11-misc/xstroke/files/xstroke-0.6-underlinking.patch
new file mode 100644
index 000000000000..52b39ddf4512
--- /dev/null
+++ b/x11-misc/xstroke/files/xstroke-0.6-underlinking.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -40,7 +40,7 @@
+ BUILT_SOURCES = rec_parse.h rec_lex.h rec_lex.c
+ AM_YFLAGS = -d
+
+-xstroke_LDADD = @XSTROKE_LIBS@ -lm -lpthread $(X_LIBS) -lXpm -lXtst
++xstroke_LDADD = @XSTROKE_LIBS@ -lm -lpthread $(X_LIBS) -lXpm -lXtst -lX11 -lXrender -lXext -ldl
+ AM_CFLAGS = @XSTROKE_CFLAGS@ -DXSTROKE_CONF_DIR='"$(sysconfdir)/xstroke"' $(X_CFLAGS)
+
+ EXTRA_DIST = xstroke_active.xpm xstroke_inactive.xpm etc/alphabet
diff --git a/x11-misc/xstroke/xstroke-0.6-r1.ebuild b/x11-misc/xstroke/xstroke-0.6-r1.ebuild
index f817fba27d23..813bf71f233f 100644
--- a/x11-misc/xstroke/xstroke-0.6-r1.ebuild
+++ b/x11-misc/xstroke/xstroke-0.6-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/xstroke-0.6-r1.ebuild,v 1.7 2012/05/05 04:53:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/xstroke-0.6-r1.ebuild,v 1.8 2012/09/12 01:51:34 jer Exp $
-inherit eutils
+EAPI=4
+inherit autotools eutils
DESCRIPTION="Gesture/Handwriting recognition engine for X"
# Dead upstream?
@@ -15,27 +16,29 @@ SLOT="0"
KEYWORDS="alpha ~amd64 hppa ~mips ppc sparc x86"
IUSE=""
-RDEPEND="x11-libs/libXtst
+RDEPEND="
x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
x11-libs/libXpm
x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXft"
-DEPEND="${RDEPEND}
- media-libs/freetype
- media-libs/fontconfig
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
virtual/pkgconfig
- x11-proto/xextproto
+ virtual/yacc
x11-proto/inputproto
- x11-proto/xproto"
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}/${P}-sigsegv_sprintf.patch"
+ x11-proto/xextproto
+ x11-proto/xproto
+"
-}
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
-src_install() {
- make DESTDIR="${D}" BINDIR=/usr/bin install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-sigsegv_sprintf.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
+ eautoreconf
}