summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libXt/libXt-1.0.4.ebuild')
-rw-r--r--x11-libs/libXt/libXt-1.0.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-libs/libXt/libXt-1.0.4.ebuild b/x11-libs/libXt/libXt-1.0.4.ebuild
new file mode 100644
index 000000000000..0aded4659c23
--- /dev/null
+++ b/x11-libs/libXt/libXt-1.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/libXt-1.0.4.ebuild,v 1.1 2006/11/09 15:51:35 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic
+
+DESCRIPTION="X.Org Xt library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+RESTRICT="mirror"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ x11-proto/xproto
+ x11-proto/kbproto"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+}