summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/fox/fox-1.0.29.ebuild')
-rw-r--r--x11-libs/fox/fox-1.0.29.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/x11-libs/fox/fox-1.0.29.ebuild b/x11-libs/fox/fox-1.0.29.ebuild
deleted file mode 100644
index 039c370b3dff..000000000000
--- a/x11-libs/fox/fox-1.0.29.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.0.29.ebuild,v 1.3 2003/09/07 00:23:27 msterret Exp $
-
-IUSE="cups opengl"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily a nd effectively"
-
-SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
-
-HOMEPAGE="http://www.fox-toolkit.org"
-
-SLOT="0"
-KEYWORDS="~x86 ~sparc "
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc
- virtual/x11
- opengl? ( virtual/opengl )"
-
-
-src_compile() {
-
- local myconf
-
- use opengl || myconf="$myconf --with-opengl=no" #default enabled
- use cups && myconf="$myconf --enable-cups" #default disabled
-
- ./configure \
- --prefix=/usr \
- --mandir='${prefix}'/share/man \
- --host=${CHOST} \
- ${myconf} || die "Configuration Failed"
-
- emake || die "Parallel Make Failed"
-}
-
-src_install () {
-
- make prefix=${D}/usr/ \
- install || die "Installation Failed"
-
- dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
-
- dodir /usr/share/doc/${PF}/html
- mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
- rmdir ${D}/usr/fox/html
- rmdir ${D}/usr/fox
-}