summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/gunicorn/gunicorn-0.15.0.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-0.15.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-servers/gunicorn/gunicorn-0.15.0.ebuild b/www-servers/gunicorn/gunicorn-0.15.0.ebuild
new file mode 100644
index 000000000000..42a8d0e4994a
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-0.15.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.15.0.ebuild,v 1.1 2012/10/24 00:39:44 rafaelmartins Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools"
+
+DOCS="README.rst"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}"-0.14.0-noegg.patch || die
+}