summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/postgresql/postgresql-9.4.ebuild')
-rw-r--r--virtual/postgresql/postgresql-9.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/virtual/postgresql/postgresql-9.4.ebuild b/virtual/postgresql/postgresql-9.4.ebuild
new file mode 100644
index 000000000000..1fbf2490776f
--- /dev/null
+++ b/virtual/postgresql/postgresql-9.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/postgresql/postgresql-9.4.ebuild,v 1.1 2014/11/02 12:42:31 titanofold Exp $
+
+EAPI=5
+
+DESCRIPTION="Virtual package to ease the transition to unified PostgreSQL ebuilds"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+IUSE="kerberos ldap server threads"
+
+DEPEND="
+ || (
+ (
+ dev-db/postgresql-base:${SLOT}[kerberos=,ldap=,threads=]
+ server? ( dev-db/postgresql-server:${SLOT} )
+ )
+ dev-db/postgresql:${SLOT}[kerberos=,ldap=,server=,threads=]
+ )
+"
+RDEPEND="${DEPEND}"