summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/selinux-sources/selinux-sources-2.4.21-r2.ebuild')
-rw-r--r--sys-kernel/selinux-sources/selinux-sources-2.4.21-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/selinux-sources/selinux-sources-2.4.21-r2.ebuild b/sys-kernel/selinux-sources/selinux-sources-2.4.21-r2.ebuild
new file mode 100644
index 000000000000..b67992e7fa83
--- /dev/null
+++ b/sys-kernel/selinux-sources/selinux-sources-2.4.21-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/selinux-sources/selinux-sources-2.4.21-r2.ebuild,v 1.1 2003/08/14 18:50:19 pebenito Exp $
+
+IUSE="selinux"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel
+#KV="2.4.21-selinux"
+
+S=${WORKDIR}/linux-${KV}
+DESCRIPTION="LSM patched kernel with SELinux"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+
+HOMEPAGE="http://www.kernel.org/ http://www.nsa.gov/selinux"
+KEYWORDS="~x86"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ kernel_src_unpack
+}
+
+src_install() {
+ kernel_src_install
+
+ dosed 's:-r0::' /usr/src/linux-${KV}/Makefile
+}
+