summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r2.ebuild')
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r2.ebuild111
1 files changed, 0 insertions, 111 deletions
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r2.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r2.ebuild
deleted file mode 100644
index 6ee48a9ddad9..000000000000
--- a/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r2.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r2.ebuild,v 1.6 2003/03/24 23:34:01 drobbins Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=2.4.20
-[ "${PR}" == "r0" ] && KV=${OKV}-openmosix || KV=${OKV}-openmosix-${PR}
-EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# 2.4.20, plus:
-# 2.4.20 openmosix-2.4.20-1
-# 2.4.20 evms-1.2.1 (evms-linux-2.4.20-common-files, evms-1.2.1-linux-2.4.patch, linux-2.4.20.VFS-lock.patch)
-
-DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.openmosix.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 -ppc -sparc -alpha"
-
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
- mv linux-${OKV} linux-${KV} || die
- cd ${S}
- cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
-
-
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- cd ${S}
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
- Makefile.orig > Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
- rm Makefile~
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
- make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R root:root *
- chmod -R a+r-w+X,u+w *
-
-
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux ]
- then
- rm -f ${ROOT}usr/src/linux
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
- fi
-}