summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/libtool/libtool-1.5.24.ebuild')
-rw-r--r--sys-devel/libtool/libtool-1.5.24.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/libtool/libtool-1.5.24.ebuild b/sys-devel/libtool/libtool-1.5.24.ebuild
index 84c46c068535..43ab83ffef92 100644
--- a/sys-devel/libtool/libtool-1.5.24.ebuild
+++ b/sys-devel/libtool/libtool-1.5.24.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.24.ebuild,v 1.7 2007/08/19 05:30:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.24.ebuild,v 1.8 2007/08/20 04:25:43 vapier Exp $
inherit eutils
DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
+HOMEPAGE="http://www.gnu.org/software/libtool/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="1.5"
KEYWORDS="~alpha amd64 arm hppa ~ia64 m68k ~mips ppc ~ppc64 s390 sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE=""
+IUSE="vanilla"
RDEPEND="sys-devel/gnuconfig
>=sys-devel/autoconf-2.60
@@ -43,6 +43,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ use vanilla && return 0
+
# Make sure non of the patches touch ltmain.sh, but rather ltmain.in
rm -f ltmain.sh*
@@ -85,7 +87,7 @@ src_install() {
local x
for x in libtool libtoolize ; do
help2man ${x} > ${x}.1
- doman ${x}.1
+ doman ${x}.1 || die
done
for x in $(find "${D}" -name config.guess -o -name config.sub) ; do