summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/nss_ldap/files/nss_ldap-220-db4.2-patch.diff')
-rw-r--r--sys-auth/nss_ldap/files/nss_ldap-220-db4.2-patch.diff50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-auth/nss_ldap/files/nss_ldap-220-db4.2-patch.diff b/sys-auth/nss_ldap/files/nss_ldap-220-db4.2-patch.diff
new file mode 100644
index 000000000000..ea3309ecf1a8
--- /dev/null
+++ b/sys-auth/nss_ldap/files/nss_ldap-220-db4.2-patch.diff
@@ -0,0 +1,50 @@
+diff -urN nss_ldap-215/configure.in nss_ldap-215-modified/configure.in
+--- nss_ldap-215/configure.in 2004-01-07 07:02:15.000000000 -0600
++++ nss_ldap-215-modified/configure.in 2004-03-18 19:47:13.111404704 -0600
+@@ -133,6 +133,9 @@
+ AC_CHECK_HEADERS(db1/db.h)
+ AC_CHECK_HEADERS(db_185.h)
+ AC_CHECK_HEADERS(db3/db_185.h)
++AC_CHECK_HEADERS(db4/db_185.h)
++AC_CHECK_HEADERS(db4.1/db_185.h)
++AC_CHECK_HEADERS(db4.2/db_185.h)
+ AC_CHECK_HEADERS(alignof.h)
+ AC_CHECK_HEADERS(rpc/rpcent.h)
+ AC_CHECK_HEADERS(sys/byteorder.h)
+diff -urN nss_ldap-215/ldap-nss.c nss_ldap-215-modified/ldap-nss.c
+--- nss_ldap-215/ldap-nss.c 2004-01-07 07:02:15.000000000 -0600
++++ nss_ldap-215-modified/ldap-nss.c 2004-03-18 19:48:19.139366928 -0600
+@@ -72,7 +72,13 @@
+ #include <sasl.h>
+ #endif
+ #ifdef AT_OC_MAP
+-#ifdef HAVE_DB3_DB_185_H
++#ifdef HAVE_DB4_2_DB_185_H
++#include <db4.2/db_185.h>
++#elif defined(HAVE_DB4_1_DB_185_H)
++#include <db4.1/db_185.h>
++#elif defined(HAVE_DB4_DB_185_H)
++#include <db4/db_185.h>
++#elif defined(HAVE_DB3_DB_185_H)
+ #include <db3/db_185.h>
+ #elif defined(HAVE_DB_185_H)
+ #include <db_185.h>
+diff -urN nss_ldap-215/util.c nss_ldap-215-modified/util.c
+--- nss_ldap-215/util.c 2004-01-07 07:02:15.000000000 -0600
++++ nss_ldap-215-modified/util.c 2004-03-18 19:49:16.347669944 -0600
+@@ -84,7 +84,14 @@
+ * right API!
+ */
+ #if defined(RFC2307BIS) || defined(AT_OC_MAP)
+-#ifdef HAVE_DB3_DB_185_H
++#define DN2UID_CACHE
++#ifdef HAVE_DB4_2_DB_185_H
++#include <db4.2/db_185.h>
++#elif defined(HAVE_DB4_1_DB_185_H)
++#include <db4.1/db_185.h>
++#elif defined(HAVE_DB4_DB_185_H)
++#include <db4/db_185.h>
++#elif defined(HAVE_DB3_DB_185_H)
+ #include <db3/db_185.h>
+ #define DN2UID_CACHE
+ #elif defined(HAVE_DB_185_H)