summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r1.ebuild')
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r1.ebuild96
1 files changed, 0 insertions, 96 deletions
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r1.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r1.ebuild
deleted file mode 100644
index a64537e31fe0..000000000000
--- a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.4-r1.ebuild,v 1.1 2015/03/09 00:36:52 prometheanfire Exp $
-
-EAPI=5
-
-inherit eutils multilib multilib-minimal prefix user
-
-DESCRIPTION="NSS module for name lookups using LDAP"
-HOMEPAGE="http://arthurdejong.org/nss-pam-ldapd/"
-SRC_URI="http://arthurdejong.org/nss-pam-ldapd/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug kerberos sasl +pam"
-
-DEPEND="
- net-nds/openldap[${MULTILIB_USEDEP}]
- sasl? ( dev-libs/cyrus-sasl[${MULTILIB_USEDEP}] )
- kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
- pam? ( virtual/pam[${MULTILIB_USEDEP}] )
- !sys-auth/nss_ldap
- !sys-auth/pam_ldap"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- enewgroup nslcd
- enewuser nslcd -1 -1 -1 nslcd
-}
-
-src_prepare() {
- # support user patches
- epatch_user
-}
-
-multilib_src_configure() {
- # nss libraries always go in /lib on Gentoo
- myconf="
- --enable-warnings
- --with-ldap-lib=openldap
- --with-ldap-conf-file=/etc/nslcd.conf
- --with-nslcd-pidfile=/run/nslcd/nslcd.pid
- --with-nslcd-socket=/run/nslcd/socket
- $(use_enable debug)
- $(use_enable kerberos)
- $(use_enable pam)
- $(use_enable sasl)"
-
- if multilib_is_native_abi ; then
- myconf+=" --with-pam-seclib-dir=${EPREFIX}/$(get_libdir)/security"
- myconf+=" --libdir=${EPREFIX}/$(get_libdir)"
- else
- myconf+=" --with-pam-seclib-dir=/$(get_libdir)/security"
- myconf+=" --libdir=/$(get_libdir)"
- fi
-
- if use x86-fbsd; then
- myconf+=" --with-nss-flavour=freebsd"
- else
- myconf+=" --with-nss-flavour=glibc"
- fi
-
- ECONF_SOURCE=${S} econf ${myconf}
-}
-
-multilib_src_install_all() {
- # for socket and pid file (not needed bug 452992)
- #keepdir /run/nslcd
-
- # init script
- newinitd "${FILESDIR}"/nslcd-init-r1 nslcd
-
- # make an example copy
- insinto /usr/share/nss-pam-ldapd
- doins nslcd.conf
-
- fperms o-r /etc/nslcd.conf
-}
-
-pkg_postinst() {
- echo
- elog "For this to work you must configure /etc/nslcd.conf"
- elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
- echo
- elog "In order to use nss-pam-ldapd, nslcd needs to be running. You can"
- elog "start it like this:"
- elog " # /etc/init.d/nslcd start"
- echo
- elog "You can add it to the default runlevel like so:"
- elog " # rc-update add nslcd default"
- elog
- elog "If you are upgrading, keep in mind that /etc/nss-ldapd.conf"
- elog " is now named /etc/nslcd.conf"
- echo
-}