summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xinetd/xinetd-2.3.14.ebuild')
-rw-r--r--sys-apps/xinetd/xinetd-2.3.14.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/xinetd/xinetd-2.3.14.ebuild b/sys-apps/xinetd/xinetd-2.3.14.ebuild
new file mode 100644
index 000000000000..1cc36cdbf7d4
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.14.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.14.ebuild,v 1.1 2005/10/30 03:37:26 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="powerful replacement for inetd"
+HOMEPAGE="http://www.xinetd.org/"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="tcpd"
+
+DEPEND="tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+PROVIDE="virtual/inetd"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp Makefile.in{,.orig}
+ epatch "${FILESDIR}"/${P}-DESTDIR.patch
+ epatch "${FILESDIR}"/${P}-install-contrib.patch
+ epatch "${FILESDIR}"/${P}-config.patch
+}
+
+src_compile() {
+ econf \
+ $(use_with tcpd libwrap) \
+ --with-loadavg \
+ || die "econf failed"
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ make install install-contrib DESTDIR="${D}" || die "failed install"
+
+ newinitd "${FILESDIR}"/xinetd.rc6 xinetd || die
+ newconfd "${FILESDIR}"/xinetd.confd xinetd || die
+
+ newdoc contrib/xinetd.conf xinetd.conf.dist.sample
+ dodoc AUDIT INSTALL README TODO CHANGELOG
+}
+
+pkg_postinst() {
+ einfo "This ebuild introduces the /etc/xinetd.d includedir with a default"
+ einfo "/etc/xinetd.conf file. Check your config files if you're upgrading from an older"
+ einfo "ebuild version. You should browse /etc/xinetd.conf and the files in /etc/xinetd.d."
+ ewarn
+ ewarn "PLEASE NOTE: Everything is off by default with access restricted to localhost."
+ ewarn
+ einfo "Check /etc/conf.d/xinetd for the startup options."
+ echo ""
+}