summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/i2c/i2c-2.7.0.ebuild')
-rw-r--r--sys-apps/i2c/i2c-2.7.0.ebuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/sys-apps/i2c/i2c-2.7.0.ebuild b/sys-apps/i2c/i2c-2.7.0.ebuild
index 8f4aea5f1dc0..65c90857870e 100644
--- a/sys-apps/i2c/i2c-2.7.0.ebuild
+++ b/sys-apps/i2c/i2c-2.7.0.ebuild
@@ -1,39 +1,45 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.6 2003/09/08 08:02:45 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.7 2003/10/03 15:09:55 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="I2C Bus support"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
-HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ~ppc"
-LICENSE="GPL-2"
DEPEND="virtual/linux-sources"
-src_compile () {
- emake LINUX_INCLUDE_DIR=/usr/include/linux clean all || \
- die "i2c requires the source of a compatible kernel\nversion installed in /usr/src/linux\nand kernel i2c *disabled* or *enabled as a module*"
+src_compile() {
+ if [ ! `emake LINUX_INCLUDE_DIR=/usr/include/linux clean all` ] ; then
+ eerror "i2c requires the source of a compatible kernel"
+ eerror "version installed in /usr/src/linux"
+ eerror "and kernel i2c *disabled* or *enabled as a module*"
+ die "make failed"
+ fi
}
-src_install () {
- emake LINUX_INCLUDE_DIR=/usr/include/linux DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+src_install() {
+ emake \
+ LINUX_INCLUDE_DIR=/usr/include/linux \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ install || die
dodoc CHANGES INSTALL README
}
pkg_postinst() {
[ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
- einfo "*****************************************************************"
einfo
einfo "i2c package installed ..."
einfo
einfo "IMPORTANT ... if you are installing this package you need to either"
einfo "IMPORTANT ... *disable* kernel i2c support or *enable it as a module*"
einfo
- einfo "*****************************************************************"
}