summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog8
-rw-r--r--sci-mathematics/coq/coq-8.1_p3-r1.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index ff650e7805d3..d26c0f352712 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/coq
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.33 2008/08/06 20:21:14 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.34 2008/10/17 15:23:12 aballier Exp $
+
+*coq-8.1_p3-r1 (17 Oct 2008)
+
+ 17 Oct 2008; Alexis Ballier <aballier@gentoo.org> +coq-8.1_p3-r1.ebuild:
+ EAPI-2 revision; force ocaml 3.10 and camlp5 support now that it's stable
+ everywhere needed so that it can build with ocaml 3.11
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-mathematics/coq/coq-8.1_p3-r1.ebuild b/sci-mathematics/coq/coq-8.1_p3-r1.ebuild
new file mode 100644
index 000000000000..8cac9707d9c1
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.1_p3-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.1_p3-r1.ebuild,v 1.1 2008/10/17 15:23:12 aballier Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+
+RESTRICT="strip installsources"
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/${PN}/V${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="norealanalysis ide debug +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ >=dev-ml/camlp5-5.09[ocamlopt?]
+ ide? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-noocamlopt.patch"
+ epatch "${FILESDIR}/${P}-cmxa-install.dpatch"
+}
+
+src_configure() {
+ local myconf="--prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/coq \
+ --mandir /usr/man \
+ --emacslib /usr/share/emacs/site-lisp \
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --camlp5dir +camlp5"
+
+ use debug && myconf="--debug $myconf"
+ use norealanalysis && myconf="$myconf --reals no"
+ use norealanalysis || myconf="$myconf --reals all"
+
+ if use ide; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+
+ ./configure $myconf || die "configure failed"
+
+ if use ide; then
+ labldir=/usr/$(get_libdir)/ocaml/lablgtk2
+ sed -i -e "s|BYTEFLAGS=|BYTEFLAGS=-I ${labldir} |" Makefile
+ sed -i -e "s|OPTFLAGS=|OPTFLAGS=-I ${labldir} |" Makefile
+ sed -i -e "s|COQIDEFLAGS=.*|COQIDEFLAGS=-thread -I ${labldir}|" Makefile
+ fi
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ if use ide; then
+ domenu "${FILESDIR}/coqide.desktop"
+ fi
+}