summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog7
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.8.4.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index 3199ad4d5573..cdac86fd8eb3 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/wxmaxima
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.28 2009/11/12 18:14:00 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.29 2009/12/18 05:05:26 grozin Exp $
+
+*wxmaxima-0.8.4 (18 Dec 2009)
+
+ 18 Dec 2009; Andrey Grozin <grozin@gentoo.org> +wxmaxima-0.8.4.ebuild:
+ Version bump
*wxmaxima-0.8.3a (12 Nov 2009)
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.8.4.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.8.4.ebuild
new file mode 100644
index 000000000000..d41b5b4757bc
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.8.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-0.8.4.ebuild,v 1.1 2009/12/18 05:05:26 grozin Exp $
+
+WX_GTK_VER="2.8"
+EAPI="2"
+inherit wxwidgets fdo-mime
+
+MYP=wxMaxima-${PV}
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit."
+HOMEPAGE="http://wxmaxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="unicode"
+
+DEPEND="dev-libs/libxml2
+ x11-libs/wxGTK:2.8"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # consistent package names
+ sed -e "s:${datadir}/wxMaxima:${datadir}/${PN}:g" \
+ -i Makefile.in data/Makefile.in || die "sed failed"
+
+ sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+ -i src/wxMaxima.cpp src/wxMaximaFrame.cpp || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --enable-dnd \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG} \
+ $(use_enable unicode unicode-glyphs)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon data/wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dodir /usr/share/doc/${PF}
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}